0

New user of MacTeX here. I'm on a mac running macOS Monterey 12.5. After installing MacTeX (and checking the package using the MD5 sum) I tried typesetting the LatexTemplate in TeXShop, but get the following error:

/Library/TeX/texbin/pdflatex does not exist. TeXShop is a front end for TeX, but you also need a TeX distribution. Perhaps such a distribution was not installed or was removed during a system upgrade. If so, go to http://tug.org/mactex and follow the instructions to install MacTeX or BasicTeX.

In the finder, if I go to /Library/TeX I can find the texbin alias. But, in terminal, if I run which pdflatex it returns pdflatex not found. Running sudo which pdflatex and typing in my administrator password returns /Library/TeX/texbin/pdflatex as expected.

In TeXShop preferences, my Path Settings under the Engine tab have been set to /Library/TeX/texbin and /usr/local/bin as suggested elsewhere on tex.stackexchange.

Is there some issue with Library permissions in macOS Monterey? I've enabled full disk access for TeXShop and TeX Live Utility in system preferences but it hasn't helped. I've also removed all my old versions of TeX, the GUI applications, and the TeX Distribution Data Structure and done a complete reinstall of MacTeX but that hasn't helped either.

6
  • 1
    Seems like a permissions' problem... I don't use mac but does your user have access to the folder /Library/TeX/texbin/ (ls -l on the folder command will possibly help to check that).
    – koleygr
    Commented Aug 11, 2022 at 8:07
  • Welcome to TeX.SE.
    – Mico
    Commented Aug 11, 2022 at 11:33
  • What does which pdflatex (no sudo) give? Do you have special permissions set for /usr or /usr/local? Did you insatll the full MacTeX? Commented Aug 11, 2022 at 12:32
  • Yeah, I suspect it's a permissions problem with the Library folder. ls -l /Library/TeX/texbin returns ls: /Library/TeX/texbin: Permission denied lrwx------ 1 root wheel 29 Aug 9 17:43 /Library/TeX/texbin
    – Tor Odden
    Commented Aug 12, 2022 at 7:46
  • /usr and /usr/local seem fine, permissions-wise. I don't think the problem lies there. For example, ls -l /usr/local returns drwxr-xr-x for /usr/local. Is there any way around this? I assumed giving TeXShop full disk access would allow it to access the /Library folder, but it doesn't seem the case. In case it's helpful, I'm running an administrator account. I also did install the full MacTeX, downloaded from tug.org/mactex/mactex-download.html using Safari and checked using the MD5 sum.
    – Tor Odden
    Commented Aug 12, 2022 at 7:54

1 Answer 1

1

Update: it appears that the aliases located at /Library/TeX/ are broken for some reason, or are otherwise inaccessible to TeXShop due to permissions issues. When I set the (pdf)TeX Path settings in TeXShop to /usr/local/texlive/2022/bin/universal-darwin/ it was able to compile.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .