I'm using geometry package in the following code. At the moment, in a page without footnotes, the margins are all 15mm, which is what I expect.

However, in a page with footnotes, e.g., Page 3, we notice that the bottom margin (that does not cover the footnotes) is larger than 15mm. Does anyone know if there is a way to make this margin exactly equal to 15mm?







1 \lipsum*[1]%~\footnote{abc}

2 \lipsum*[1]

3 \lipsum*[1]

4 \lipsum*[1]

5 \lipsum*[1]%~\footnote{abc}

6 \lipsum*[1]

7 \lipsum*[1]

8 \lipsum*[1]

9 \lipsum*[1]

10 \lipsum*[1]~\footnote{abc}

11 \lipsum*[1]

12 \lipsum*[1]

13 \lipsum*[1]~\footnote{abc}

14 \lipsum*[1]

15 \lipsum*[1]

16 \lipsum*[1]

17 \lipsum*[1]

18 \lipsum*[1]

19 \lipsum*[1]

20 \lipsum*[1]

  • heightrounded is said to round the total height to a multiple of \baselineskip+\topskip. Does it help if you remove it? There’s also an option to remove footer with nofoot.
    – Celdor
    Aug 11, 2022 at 23:46
  • Removing heightrounded doesn't help. "There’s also an option to remove footer with nofoot." ==> I don't understand what you mean.
    – SoftTimur
    Aug 12, 2022 at 0:58

1 Answer 1


The footnotes are smaller than normal text, so they don't constitute an integral number of the normal line height (\baselineskip). And there isn't enough space to fit another line of text. So there is some unused space at the bottom.

You can use the \flushbottom command to let LaTeX stretch the page so that it fits to the bottom, but that will make the space between the pagaraphs on that page a bit larger. Put the command somewhere before \begin{document}.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .