0

Compiling my .tex files gives me errors such as missing the required styles and libraries. For example like this:

Pdflatex: security risk: running with elevated privileges
This is pdfTex, Version 3.141592653-2.6-1.40.24 <MiKTeX 22.3> <preloaded format = pdflatex.fmt>
Restricted \write18 enabled.
Entering extended mode
<C:/Users/ B/Documents/main.tex
LaTeX2e <2021-11-15> patch level 1
L3 programming layer <2022-02-24>
<C:\Program Files\MiKTeX\tex/latex/base\article.cls
Document Class: article 2021/10/04 v1.4n Standard LaTeX document class
<C:\Program Files\MiKTeX\tex/latex/base\size10.clo>>
<C:\ Program Files\MiKTeX\tex/latex/base\fontenc.sty
========================================================================
Unfortunately, the package Cyrillic could not be installed.
Please check the log file:
C:\Users\  B  \AppData\Local\MiKTeX\miktex\log\pdflatex.log
========================================================================

Package foentenc Error: Encoding file ‘t2aenc.def’ not found.
<fontenc>       You might have misspelt the name of the encoding.

See the fontenc package documentation for explanation.
Type H<return> for immediate help.
…
l.111 \ProcessOptions*

Therefore, I've tried to install such libraries separately. The MiKTeX has (https://miktex.org/packages/markdown/files) different additions for perfect compilation of different types of files and libraries usage. But I didn't find how can I get them (github suggests from different authors) How can I get .sty separately?

6
  • It's probably easiest to use the package manager that comes with MikTeX, i.e. the MiKTeX Console. Downloading from CTAN is another option, but is generally a little bit more difficult.
    – Ingmar
    Aug 15 at 7:51
  • You should install them in aLocalTeXMF directory, respecting the structure of a TeX directory, and you declare it through MiKTeX Settings.
    – Bernard
    Aug 15 at 7:55
  • I think I should re-install my MiKTeX, because it cannot install packages even from the console mode with administrator rights. It always shows the SSL connect error Aug 15 at 8:02
  • That SSL error might just be a bad mirror with an expired SSL cert. You could just choose a different mirror.
    – daleif
    Aug 15 at 8:11
  • Try TeXLive, by default make a full installation and therefore take some time, but after that, very rarely you will need download anything else. The bad news are that packages are upgradable only for some moths, them the year version is frozen, and you must to expect some time to install (better that upgrade) the next version, but once installed properly, no problem of downloads at demand.
    – Fran
    Aug 15 at 9:29

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.