0

I am using the kaobook template for my PhD thesis. It can be found here on Overleaf.

Due to design reasons, I do not call \chapter{...}, but simply increment the chapter counter manually. Because I never call \chapter, there is no space between the chapters in the ToF and ToT (see attached picture). Can I somehow "fake-call" \chapter, or redefine the section command (which is already redefined in the kao.sty file) to get the space back?

I tried to look for a solution, but most other questions are interested in removing the extra space, and don't have to deal with the problem of never having declared a new chapter.

enter image description here

6
  • \i don't go near Overleaf. Please provide an MWE (from \documentclass... to \end{document}) that we can compile that shows what you have done and what the problem is. (What iare ToF and ToT?) Aug 18, 2022 at 19:03
  • I figured that if ToC = Table of Contents, then surely ToF = Table of Figures. Apparently that is LoF though. Aug 19, 2022 at 6:04
  • But the LaTeX commands are listoffigures and \listoftables which create "List of Figures" and "List of Tables". Aug 19, 2022 at 18:36
  • You have still not provided an MWE so we don't know what you have done and therefor the cause of your problem is a mystery. --- GOM Aug 19, 2022 at 18:46
  • I don't think an MWE is feasible for me here. I would need to take apart the whole template, and this would take days. Even more so, I don't think it is necessary, as the whole code is just there, if one were to follow the link. No idea why Overleaf is a problem, but I guess that is another philosophical discussion. But I solved the problem myself anyway, just keeping the question here for posterity. Aug 23, 2022 at 13:26

1 Answer 1

-1

While surely not the most elegant answer, this is how I did it. I added the two lines below, between the two sections that I wanted to split (i.e., at the start of the second and third chapter/part). The 0.7 is a manual tweak, I couldn't figure out the exact spacing in the template.

\addtocontents{lof}{\vspace{0.7\normalbaselineskip}} 
\addtocontents{lot}{\vspace{0.7\normalbaselineskip}} 

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .