I write latex documents in Article class, nothing fancy but some pstricks code and .eps pictures included. For some reason the latex->dvips->ps2pdf routine produces .pdf files that are badly handled by the professionnal printer at work ; horizontal lines do not appear.

So I guess I need to use pdflatex, along with -shell-escape and the [auto-pst-pdf] package to produce a correct .pdf file.

Here is an exemple file.tex :




Some maths : $\frac 12 + \frac 12 = 1$. A picture : 

\begin{pspicture}(-2,-1.5) (2,1.5) 
 \psaxes[labels=none, ticks=none]{->}(0,0)(-2,-1.5) (2,1.5) 


I compile this using pdflatex -interaction=nonstopmode -shell-escape file.tex

However 3 issues come with this :

  1. [auto-pst-pdf] creates an auxilliary -pics.pdf file, cluttering my clean folders. Any method to remove the -pics.pdf file automatically during compilation ?

  2. The .pdf file created is about 10 times the size than with latex->dvips->ps2pdf, not very good for mailing purposes.

  3. The compilation time is very long, also about 10 times the time of the whole latex->dvips->ps2pdf, annoying.

Any ideas to help me with those issues will be appreciated.

  • I don't see why using auto-pst-pdf should improve your pdf, all that means is each tikz is saved to a separate file, run through latex-dvips-ps2pdf chain you were using then the resulting pdf of each one separately included as a pdf graphic. You could try lualatex with its new direct pstricks support implemented in Lua. Aug 23, 2022 at 13:05
  • Thank you David for your answer. It is true that pdflatex does not seem to improve over the latex-dvips-ps2pdf chain. After a little research it appears that it does, because the dvips part included in pdflatex use the dvips -Ppdf option, which seem to increase the quality of the ps, and the pdf file created.
    – guigui
    Aug 23, 2022 at 13:23
  • The pstricks processing is identical, it is just a covenience if your document is otherwise using pdflatex to run latex/dvips/ps2pdf for you in the background (you could use -Ppdf for your main document as well) Aug 23, 2022 at 13:25
  • So I just tried to ditch pdflatex, and use the regular chain latex-dvips[with -Ppdf option]-ps2pdf again. It works and prints correctly. However 2 issues remain : dvips -Ppdf is very slow (20 seconds for a 10 pages documents), and the .ps file created is huge : 100MB with nothing fancy inside
    – guigui
    Aug 23, 2022 at 13:27
  • 1
    20 seconds for 10 pages, I remember when 15 minutes per page was thought acceptable ... Aug 23, 2022 at 14:00

1 Answer 1


Well it seems I could get around all of this.

First the problem : with the usual latex->dvips->ps2pdf routine, the .pdf file created did not print correclty on a professional printer : horizontal lines did not appear.

Now the solution :

  • In my case, it has to do with dvips rendering horizontal lines at a too low resolution of 600dpi.
  • You can set dvips to render at a fixed resolution, says 8000dpi, via dvips -D8000 filename.tex
  • This may make dvips very long and produce enormous .ps files of more than 100MB. This seems to be because it sometimes has to rescale some unusual fonts.
  • If this is the case, try adding \usepackage{lmodern} to your preambule to load some fonts friendly with dvips. (The only drawback of package lmodern that occured is that it does not handle \textsc in boldface)

So basically, if some lines do not appear at printing : latex -> dvips -D8000 filename.tex -> ps2pdf filename.ps, print filename.pdf

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .