I'm using Obsidian to write markdown text in order to export to PDF using pandoc PDFLateX. I'm using using tufte-book class and it's working perfect. The problem is that I'm trying to use kaobook class, but the citations that are automatically shown as sidenote in tufte are being shown as footnote in kaobook.

Is there a way to setup kaoobook to consider all citations as sidenotes automatically as tufte-book class do?

This is the outcome using tufte-book class: enter image description here

This is the outcome using kaobook class: enter image description here

This is the basic code using kaobook template:

% Options for packages loaded elsewhere
  \usepackage{textcomp} % provide euro and other symbols
\else % if luatex or xetex
% Use upquote if available, for straight quotes in verbatim environments
\IfFileExists{microtype.sty}{% use microtype if available
  \UseMicrotypeSet[protrusion]{basicmath} % disable protrusion for tt fonts
\@ifundefined{KOMAClassName}{% if non-KOMA class
  }{% else
    \setlength{\parskip}{6pt plus 2pt minus 1pt}}
}{% if KOMA class
\setlength{\emergencystretch}{3em} % prevent overfull lines
\setcounter{secnumdepth}{-\maxdimen} % remove section numbering
\newlength{\cslentryspacingunit} % times entry-spacing
\newenvironment{CSLReferences}[2] % #1 hanging-ident, #2 entry spacing
 {% don't indent paragraphs
  % turn on hanging indent if param 1 is 1
  \ifodd #1
  % set entry spacing
\newcommand{\CSLRightInline}[1]{\parbox[t]{\linewidth - \csllabelwidth}{#1}\break}
% get rid of language-specific shorthands (see #6817):
  \usepackage{selnolig}  % disable illegal ligatures
\IfFileExists{xurl.sty}{\usepackage{xurl}}{} % add URL line breaks if available
\urlstyle{same} % disable monospaced font for URLs
  pdfauthor={Christian M. De Britto},
  pdfcreator={LaTeX via pandoc}}

\author{Christian M. De Britto}


\section{Cidade e transformação}\label{cidade-e-transformauxe7uxe3o}}

\subsection{Afinal de contas, o que é a

O Sociólogo alemão Georg Simmel (1858-1918) foi um dos primeiros autores
clássicos da sociologia a refletir sobre características da vida urbana.
Segundo ele, a vida urbana é marcada pela intensificação das
experiências. Em suas palavras:

O fundamento psicológico sobre o qual se eleva o tipo das
individualidades das grandes cidades é a \textbf{intensificação da vida
nervosa}, que brota da mudança acelerada e ininterrupta das impressões
interiores e exteriores.\footnote{Georg Simmel, \emph{As Grandes Cidades
  e a Vida Do Espírito} ({Covilhã}: {Universidade da Beira Interior},
  2009), 4.}

\addcontentsline{toc}{subsection}{Referências Bibliográficas}

\leavevmode\vadjust pre{\hypertarget{ref-simmel}{}}%
Simmel, Georg. \emph{As Grandes Cidades e a Vida Do Espírito}.
{Covilhã}: {Universidade da Beira Interior}, 2009.


  • 2
    You need to redefine the citation style / citation command in the document preamble. For a more decisive information you can convert the document to LaTeX and not directly to pdf, i.e., pandoc ... -s -t latex -o text.tex as a standalone document and then look how the citations are done there. That would be the command you need to adjust. You can also look for natbib / cite / biblatex inclusion the the header and check their options. It would help a lot if you would be able to provide a minimal example, short documents with which we can reproduce the issue. Commented Aug 24, 2022 at 14:40
  • 1
    Ok, thanks! As you can see, in the document the citation is actually typeset as a footnote (\footnote{Georg Simmel ...}) and then the full citation is added "manually" to the reference section. This is not the typical way it should work, though. Next point: this kind of referencing is surely done by the converter you are using. It's the tufte class, that shows any footnotes as side-notes, but you are giving LaTeX footnotes. The fix is somewhere before LaTeX. Commented Aug 24, 2022 at 15:01
  • 1
    Just an idea: check if the --natbib option of pandoc is on. Commented Aug 24, 2022 at 15:13
  • Hi @OlegLobachev I'm just using the --citeproc option, if I include --natbib the citations are gone. What am I doing wrong?
    – Britto
    Commented Aug 24, 2022 at 15:23
  • 1
    Well, as citeproc docs say, "This library generates citations and bibliography formatted according to a CSL style." This means that citeproc does all the formatting of the cites itself, so it generates the bibliography and probably also the footnotes. Without it, with natbib seems the better way for now (as long as LaTeX should be considered). Please check how the processing is done (try using latexmk, for example). You can post also the version, generated with --natbib here, it would help. Or you can post the full pandoc command and the orig. md file. Commented Aug 24, 2022 at 16:11

1 Answer 1


I don't know if this is the best solution. I inserted this command on my tex file and it's working now:

  • \usepackage{sidenotes}
  • \let\footnote=\sidenote
  • Tufte-LaTeX redefines the \footnote command so that it prints the text in the margin. kaobook doesn't do that: \footnote still makes a footnote; if you want to put something in the margin with kaobook, you should use either \sidenote or \marginnote or \sidecite. So adding \let\footnote=\sidenote to your tex file should be enough (the sidenotes package is already loaded by kaobook). Commented Sep 22, 2022 at 7:40
  • However, in kaobook and more generally in LaTeX there are more appropriate commands than \footnote or \sidenote to display citations. The recommended workflow is to create a bibTeX file with all your citations, and then in LaTeX use a package like biblatex or natbib; at that point you can just write \cite{key}, and LaTeX will take care of formatting the citation (i.e. you don't have to write the title, author, and year yourself). I don't know whether this practice works well with obsidian, though. Commented Sep 22, 2022 at 7:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .