1

After sorting out my problem with imakeidx, I still have an issue with a wrong alphabetical order of accented Hungarian entries in the index. Updated MikTeX running lualatex-dev.exe with -interaction=nonstopmode -shell-escape "%wm" and makeindex.exe with "%tm.idx" -t "%tm.ilg" -o "%tm.ind".

\documentclass[12pt]{article}
\usepackage[hungarian]{babel}
\usepackage{imakeidx}
\makeindex[program=texindy,options=-L hungarian -C utf8]

\begin{document}
\frenchspacing

Esztendők\index{óra} sora óta együtt\index{otthon} szoktam vacsorálni az István főherceg
vendéglőben az én igen t. barátommal, gróf\index{összes} Pongrácz Károly képviselővel és
tábornokkal. A hosszú téli estéken sokszor csak\index{enged} ketten ülünk a szokott
asztalnál, lenge\index{ősember} fátyol alatt, amely szivarjaink füstjéből szövődik, s ha
már kifogyott az aktuális beszélgetési anyag, szívesen\index{okozat} csúszunk kijjebb a
jelentől, az élményekben, színekben duzzadó múlt felé. Egymást ilyenkor szinte nem
is\index{éber} látjuk, hanem csak a múltat.

\printindex
\end{document}

Index

I cannot fathom what éber is doing at o and why összes and ősember are separated. The correct order should be éber, enged; okozat, óra, otthon; ősember, összes. I've checked the manual (p. 19), and the order seems to be fine there, but I was told that the implementation is not in utf8.

4
  • You don't want to run makeindex, but rather texindy.
    – egreg
    Aug 31, 2022 at 10:00
  • @egreg Non vedo nessun cambiamento, i risultati sono gli stessi con texindy.exe Aug 31, 2022 at 10:15
  • you get the faulty order if you use makeindex. With texindy it is correct. Run texindy -L hungarian -C utf8 your-file-name-here.idx on a command line and check if it actually works and if it reports problem. Aug 31, 2022 at 12:20
  • @UlrikeFischer I got an error that Perl is not installed on my PC, trying now to fix that... Sep 4, 2022 at 13:26

1 Answer 1

1

If you run lualatex-dev -shell-escape on your document, you get (without running any auxiliary program)

enter image description here

Whether the collation order is good or not is a problem of Xindy.

I tried to convert the produced .idx file into Latin-2 and run texindy with the -C latin2 option, and convert back the .ind file to UTF-8, but the result is exactly the same.

Note that makeindex will definitely go wrong.

1
  • Ok, it started to work, but strangely enough if I execute it from TeXnicCenter with the aforementioned settings, the .idx file is correctly produced, yet the .ind is an empty one. So I have to manually run texindy.exe with the same settings and I get the correct results. Do you have any ideas why it may happen? Dec 3, 2022 at 22:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .