I'm trying to use biblatex and biber so as to have access to @online, etc. But I'm quite overwhelmed.

In-text citations used to just show the last names. Now they are including first names or initials. How can I make first names/initials go away in the in-text citation?

My journal insists on (author year) rather than (author, year). Ugh, but how can I implement this for in-text citations?

  • What biblatex style are you using? The firstname/initials in most default styles are because the automatic name disambiguation system is probably enabled. You could set uniquename=false and uniquelist=false as package options. However, you won't then be able to disambiguate names in citations which is sounds like you might need to do ...
    – PLK
    Aug 3, 2012 at 17:44
  • 1
    My call is: \usepackage[firstinits=false,uniquename=false,uniquelist=false,citestyle=authoryear-comp,bibstyle=authoryear-comp ,sortcites=false,natbib=true,block=space,url=false,doi=true,backend=biber]{biblatex} after adding your two suggestions. They solve problem (1)! I doubt I have real disambiguation problems. It would be nice to know what biber/biblatex thinks is ambiguous (I couldn't tell).
    – CPBL
    Aug 3, 2012 at 17:52
  • And you still get first names/initials? If so, please say which versions of biblatex/biber you are using and also give us a minimal example showing the problem.
    – PLK
    Aug 3, 2012 at 17:53
  • Wow, you're fast. I pressed enter early and was still editing my reply. Thanks for the solution to (1)!. I still need to get rid of commas in citations, before the year. I don't know how to find the biblatex version. biber --version gives: biber version: 0.9.8.
    – CPBL
    Aug 3, 2012 at 17:59
  • For future reference, please always only ask one question per post. This way, other users looking for help can find solutions more easily.
    – doncherry
    Aug 3, 2012 at 22:35

1 Answer 1


Set uniquename=false and uniquelist=false for the first issue but note that you then can't auto-disambiguate names if you need to.

For the comma issue, put this in your preamble:


natbib compat makes nameyeardelim into \addcomma\addspace so you need to reset it.

  • Thanks PLK! For the solution AND explanations. Both my issues are solved.
    – CPBL
    Aug 3, 2012 at 18:48
  • @PLK: Please don't answer a question while it violates our one-issue-per-question rule so blatantly. See Should we answer really bad questions? The two questions asked here aren't really terrible per se, they just shouldn't be in one post. Just imagine duplicate handling with questions like this.
    – doncherry
    Aug 3, 2012 at 22:37
  • 3
    @doncherry: Btw, as the offender, is there something I should do? Is it worthwhile to edit this question to restrict it to half of what I asked, and make a new one, inviting PLK to answer that too??
    – CPBL
    Sep 30, 2014 at 19:55
  • I still get full names in fullcite with both options turned off. How can I only get the surnames?
    – Marten
    Mar 20, 2023 at 14:02
  • @Kvothe Please open a new question with a MWE
    – PLK
    Mar 23, 2023 at 8:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .