0

sometimes I get the problem that when I build my LaTex files (with Sublime 3, TexLive and SumatraPDF), that I try to double-click on any text in my pdf which should give me the code in the sublime file however at the top left it just states "Kein Synchronisationsdatei gefunden" which is german for "no synchronisation file found". What could be the issue here?

When using LatexTools to check my system all the programs seem to be "available" except for sublime itself. There it says that its available however the line states the following:

"sublime      C:\your\full\sublime\directory\subl.exe              available  Das System kann den angegebenen Pfad nicht finden."

Which translates to the system can't find the given path, however I don't know about any path I have given.

In my user settings of LatexTools I have written the following:

{
"windows": {
        // Path used when invoking tex & friends; "" is fine for MiKTeX
        // For TeXlive 2011 (or other years) use
        // "texpath" : "C:\\texlive\\2011\\bin\\win32;$PATH",
        "texpath" : "C:\\texlive\\2011\\bin\\win32;$PATH",
        // TeX distro: "miktex" or "texlive"
        "distro" : "texlive",
        // Command to invoke Sumatra. If blank, "SumatraPDF.exe" is used (it has to be on your PATH)
        "sumatra": "",
        // Command to invoke Sublime Text. Used if the keep_focus toggle is true.
        // If blank, "subl.exe" or "sublime_text.exe" will be used.
        "sublime_executable": "",
        // how long (in seconds) to wait after the jump_to_pdf command completes
        // before switching focus back to Sublime Text. This may need to be
        // adjusted depending on your machine and configuration.
        "keep_focus_delay": 0.5
    },
}

The Command for the inverse search in Sumatra I use is: "C:\Program Files\Sublime Text\sublime_text.exe" "%f:%l"

Thanks in advance

Edit: The odd thing is that I have been working some more on my project and now the synchronisation seems to be working fine. This problem just occurs sometimes and then usually goes away after some time or recompiling.

1
  • Does using the portable version of SumatraPDF fix the problem?
    – Name
    Aug 21, 2023 at 15:57

2 Answers 2

2

You can use -synctex=-1 not -synctex=1 to avoid it. Such as pdflatex -synctex=-1 test.

6
  • First off thank you however I am not quite sure what you mean by "You can use". Where do I use what you suggested and how specifically? Is it a different command for me to enter in Sumatra or should I put that somewhere in my user config? Sep 19, 2022 at 11:15
  • @RaoulLuqué I don't know what LaTeX editor you use. If you use command compilation, you can refer to my answer. If you use an editor such as TeXstudio, please open settings to modify the compilation parameters.
    – Clara
    Sep 19, 2022 at 11:21
  • I use Sublime as described in my question with texlive Sep 19, 2022 at 11:22
  • I have added your suggestion to my "builder-settings" and it seems to work fine right now, I will see whether the problem pops up again or if it's fixed. Thank you Sep 19, 2022 at 11:24
  • @RaoulLuqué I'm terribly sorry. You can find out how to modify the compilation parameters in LaTeX plug-in of Sublime Text. I suggest you try command compilation first to confirm whether the problem is solved. The editor just encapsulates the commands in GUI.
    – Clara
    Sep 19, 2022 at 11:24
1

Just to add a bit details to Clara's answer. If you are using LaTeXTools, you can add the following as the very first line in your .tex file to change the builder settings.

% !TEX options=-synctex=-1

For example:

% !TEX options=-synctex=-1
\documentclass{article}
\usepackage[margin=1in]{geometry}

See sumatrapdfreader/sumatrapdf#2741 and LaTeXTools docs.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .