0

I'm using the following command to install texlive-full on my PopOS! 22.04 LTS:

sudo apt-get instal texlive-full

It installs the following version:

TeX 3.141592653 (TeX Live 2022/dev/Debian) kpathsea version 6.3.4/dev

However, in this version, my sources do not compile. I want to install the following version:

TeX 3.14159265 (TeX Live 2020/Debian) kpathesea version 6.3.2

Is there no way to specify the TexLive version at install time via apt-get? Like:

sudo apt-get instal texlive-full version=6.3.2

Everything I've looked at on the internet is extremely boring and complicated.

7
  • 1
    TeX Live is versioned by year, so you want TL2020 by the sound of things. You can't that I know of do that using apt, but you could install 'vanilla' TeX Live 2020 from the historical archive. Before you do that, however, perhaps you could explain the specific issue that means you can't use the current release?
    – Joseph Wright
    Commented Oct 8, 2022 at 13:32
  • 3
    It is almost certainly easier and better longer term to fix your document so it works with a current system. Essentially any latex document written in the last 40 years will work with a current latex with at worst some minor changes. Commented Oct 8, 2022 at 13:37
  • I am writing my doctoral thesis. I am required to use a university LATEX class. With this 2020 version it recognizes the compile, however with this 2022 version it doesn't compile. I need to install on PopOS 22.04 the 2020 version of TexLive. When I open it with this 2022 version, a hundred errors appear starting with (Missing \begin{document}"error but \begin{document}). I've already tested it on another computer with the 2020 version and it works. However, this other computer is not mine. I need to install it on my computer. My computer runs PopOS 22.04. Commented Oct 8, 2022 at 13:39
  • 3
    It's weird that you're getting a dev version of TL 2022 on PopOS. If I'm not wrong, their texlive packages come from Ubuntu, and Ubuntu's stable repos still ship TL 2021 I believe. Have you enabled some testing or unstable package repos or ppas? But you should find out why it doesn't work with TL 2022. You don't want your thesis stuck in the past. Can you post a minimal working example of something that compiles with TL 2020 but not 2022 along with your log file?
    – frabjous
    Commented Oct 8, 2022 at 13:41
  • You can try to install the .deb for a previous Ubuntu version manually, for example from packages.ubuntu.com/focal/amd64/texlive-full/download for 20.04 (which is TeX Live 2019) or packages.ubuntu.com/impish/amd64/texlive-full/download for 21.10 (TL 2020). However, this will probably lead to dependency problems along the way. A solution could be to do a complete install of 21.10 in a virtual machine (like Docker). However, as suggested in other comments it is probably easier to fix the issues with your custom class to run on TL2022.
    – Marijn
    Commented Oct 8, 2022 at 13:46

3 Answers 3

4

Answering my own question.

  1. It is not possible to install previous versions of TexLive via apt-get using something like "version=[version]".

  2. For some reason using apt-get and PopOS! 22.04, the version of TexLive that is installed is a version of the “dev/Debian”.

TeX 3.141592653 (TeX Live 2022/dev/Debian) kpathsea version 6.3.4/dev

  1. However, if installing the vanilla version directly from TUG (https://tug.org/texlive/quickinstall.html) it worked perfectly!

TeX 3.141592653 (TeX Live 2022) kpathsea version 6.3.4

4
  • I did some digging on the USPC class that you provided a link for in the comments to the question (moved to chat). It turns out it is this bug. Downloading the latest chemmacros.sty from ctan.org/tex-archive/macros/latex/contrib/chemmacros and saving it to the same folder as your thesis solves the issue. The problem was therefore not that Ubuntu/PopOS uses a 'development' version, just that their package freeze was done before chemmacros fixed the bug.
    – Marijn
    Commented Oct 8, 2022 at 17:27
  • Note that I tested this using the apt installed version, that may not have been clear from my previous comment :) Also note that you can accept your own answer after 48 hours, instead of the borderline rude answer by Albert Nash.
    – Marijn
    Commented Oct 8, 2022 at 17:28
  • I tested it here and indeed it fixed the problem. I sent an email to the university reporting the bug and your solution. Thanks a lot for the help! (Albert probably isn't having a good day 🤗) Commented Oct 8, 2022 at 17:31
  • This is the best answer. Please accept it when you are enabled. Commented Oct 8, 2022 at 18:26
1

Why don't you install the latest version as described in their official website? https://www.tug.org/texlive/quickinstall.html

Unix(ish): Non-interactive default installation on anything but Windows:

cd /tmp # working directory of your choice
Download: wget https://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz
           or: curl -L -o install-tl-unx.tar.gz https://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz
(or via whatever other method you like)
zcat < install-tl-unx.tar.gz | tar xf -
cd install-tl-*
perl ./install-tl --no-interaction # as root or with writable destination
Finally, prepend /usr/local/texlive/YYYY/bin/PLATFORM to your PATH,
e.g., /usr/local/texlive/2024/bin/x86_64-linux 
-1

Essentially, you have asked to solve a problem between your university (with god knows how broken their class might be) and you. We cannot be responsible for that (or, at least, not directly). Having said that:

  1. Tell your university to update their classes. Set up an automatic script to complain to them via e-mail every half an hour or so.

  2. Find your version on https://snapshot.debian.org and try to use it (essentially, you'd need to downgrade many packages, perhaps even the whole operating system), but if you succeed (which I doubt), DON'T TELL ANYONE!

  3. Sue your university for not giving a shit providing you with adequate means to comply with their regulations.

Item № 2 can take anywhere between half a day (in case of success) and forever (because if you downgrade too much, the operating-system drivers might become too old to operate your machine, or the old certificates to communicate with the rest of the world may turn out to be already expired; if you decide you need an older machine for your older Debian system packages, you might be unable to find such a machine anyway). As folks said in the comments, repairing the university class is likely to be easier. Even if you do this completely on your own reading Knuth's and Lamport's books, latex.ltx, and the involved classes and styles.

4
  • 4
    There are probably more respectful and objective ways to answer the question I asked in this post. When you don't know the answer, better not post anything. Read the question again. Commented Oct 8, 2022 at 14:58
  • 1
    @CiniroNametala Don't get me wrong: I'm overly respectful to you, sir/madam/diverse. However, if your university doesn't bother updating its own classes, it is, by definition, hard on you as on any other doctoral student. They don't deserve any sort of respect (maybe, in some other matters, but definitely not in this particular matter). By no means. As for how different operating systems package their TeX Live, this is of marginal scope to this community. Debian, e.g., could be asked via a wishlist-severity report to bugs.debian.org.
    – user282514
    Commented Oct 8, 2022 at 15:20
  • OK. Thanks for not helping at all with your answers. 👋 Commented Oct 8, 2022 at 15:42
  • 1
    @CiniroNametala Ok. Given the tone of your last comment, I respectfully take my "overly respectful to you" back.
    – user282514
    Commented Oct 8, 2022 at 22:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .