7

I am following this answer to submit a latex file with minted code highlighting to arxiv. I first compile locally with:

\usepackage[finalizecache,cachedir=minted-cache]{minted}

Then I change the tex file to:

\usepackage[frozencache,cachedir=minted-cache]{minted}

When submitting to arxiv in addition to submitting the minted-cache folder. I then get during compilation on the arxiv servers:

! Package minted Error: Missing style definition for with frozencache.

See the minted package documentation for explanation.
Type H <return> for immediate help.
...

l.583 \end{minted}

Any lead on what I could try to fix it ?

5
  • Please send me support request to arXiv through our support portal with the submit-id and I'll look at your issue on Monday when I'm back in the office.
    – Jake
    Commented Oct 14, 2022 at 22:08
  • 1
    Todd'solution worked for me! I took the sty files directly from github.com/gpoore/minted/blob/master/source/minted.sty Commented Oct 17, 2022 at 1:58
  • @Jake, since Todd's solution worked for me as well no need for support !
    – jeandut
    Commented Oct 17, 2022 at 8:23
  • As @Todd said it does hint at arxiv using an older minted version.
    – jeandut
    Commented Oct 17, 2022 at 8:23
  • Note that it works with nested tex files as well
    – jeandut
    Commented Oct 17, 2022 at 8:24

1 Answer 1

8

I was able to get around this by copying minted.sty and minted1.sty from my local TeXLive distribution into the paper directory. I think the issue is that arXiv is using an older minted version than the one I built my cache with.

1
  • 3
    Thank you @Todd Gamblin it works very well !
    – jeandut
    Commented Oct 17, 2022 at 8:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .