1

I have the following file:

\documentclass[a4paper, 12pt]{report}

\usepackage{hyperref}



\begin{document}

    \tableofcontents
 
    \chapter{ch1}
    \chapter{ch2}
    \chapter{ch3}

   
\end{document}

The table of contents has small boxes that overlap with the content, as shown in the following screen shot! How to fix this?

Here is the link to screenshot:

ScreenShot

8
  • 1
    Can you add which engine you use, e.g. pdflatex or something else and which version of texlive you use (you can find both in the sidebar of your overleaf project). With pdflatex and up to date texlive22, I get i.imgur.com/UjJ74kD.png Commented Oct 13, 2022 at 11:49
  • Do you use the Overleaf viewer or the browser viewer (this setting can be found all the way down in the Overleaf menu on the left)? If you use the browser viewer, which browser is that?
    – Marijn
    Commented Oct 13, 2022 at 12:12
  • @Marijn I use overleaf PDF viewer!
    – A J
    Commented Oct 13, 2022 at 12:15
  • @samcarter_is_at_topanswers.xyz the compiler I use is pdfLatex and Tex Live version is 2022!
    – A J
    Commented Oct 13, 2022 at 12:19
  • 2
    This seems to be just a viewer issue. Your boxes look find when downloading the pdf from your overleaf project. Commented Oct 13, 2022 at 12:30

1 Answer 1

1

There is no overlap with an external viewer (okular here):

The boxes are expected because it's the default of hyperref to show links. If you don't like it, you can issue \hypersetup{colorlinks}, which will avoid boxes and just color the links (by default red, but it can be changed).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .