0

I would like to be able to open bib files from other directories from the WinEdt Tree. However, WinEdt cannot locate them (see figure below). The project/files compile; LaTeX is set up correctly. The only issue is I cannot click on the file in the tree to open it.

The file le.bib is located in my personal texmf directory structure which is added to MiKTeX. LaTeX can find and process it with \bibliography{le} but the WinEdt Tree cannot locate it.

I realize I can move the file into the project directory, but I don't wish to do this. I have common bib files that I reuse for multiple documents and don't want to duplicate them.

Ideally, I'd like to tell WinEdt a search path to look for the files. That way I don't have to hard code paths into files.

I'm using WinEdt 11. I've searched online and dug through the Options Interface, but I'm unable to find a way to get WinEdt to locate the files. Any suggestions would be appreciated.

enter image description here

1 Answer 1

0

well it works for me for \addbibresource, and I think that this code that I added at some time is doing it. But I can't test now.

If have in my local ConfigEx/Input.in

//UF implemented kpsewhich search
  DIRECTIVE="\addbibresource??{??}"
    FILENAME="%[!|Exe('%b\Macros\Input\GetBibFiles.edt');Assign('UFfiletemp','%-0');Exe('%b\Macros\Ulle\UFkpsewhich.edt');|];%$('UFfiletemppath');"
    EXTENSION="*;.bib"

The GetBibFiles.edt is a standard file. The UFkpsewhich.edt contains this

// The file to search should be in  %$('UFfiletemp')
// The returned path will be in  %$('UFfiletemppath')
//First check relative to the main file:

// Assign('UFfiletemp','citeall.sty'); // nur tests

IfFileExists("%P\%$('UFfiletemp');","Assign('UFfiletemppath','%P\%$(|UFfiletemp|);');JMP('Exit')");

// then use kpsewich
WinExe("", "kpsewhich %$('UFfiletemp');", "%b", "kpsewhich ...", 10110, 0,"","%b\_findtexmf.log");
ReadFile( "%b\_findtexmf.log", 1);
SubstituteInString( "%!1", "/", "\",0,2);
//Get rid of white space to the right:
FormatString("%!2", 3, "trimright");

Assign('UFfiletemppath','%!3');
:Exit::

//Prompt("Path: %$('UFfiletemppath');");
3
  • This seems like maybe it is on the right track, but I couldn't get it to work. I didn't have a %b\ConfigEx/Input.ini file so I added it and put the code in it. I am assuming here ini was meant and not in? I then added the UFkpsewhich.edt to %b\Macros but it didn't work.
    – Lance
    Oct 14, 2022 at 18:26
  • If you click in the options interface on Navigation -> input directives it will open a local copy of the global Input.ini. There you can find the directive for addbibresource and adapt it. Oct 14, 2022 at 18:30
  • I was able to get that fixed, but it's still not finding the file.
    – Lance
    Oct 14, 2022 at 19:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .