0

I have the Acknowlgwmnet section that does not show the page numbering. So the Dedication starts with iii, then Acknowlgment no number, then abstract had v page number. So it counts, but it doesnot show the page number. Here is my code

\documentclass[botnum, fleqn]{unmeethesis}
                 % OR
% Use the following specification for TOP page numbering:
% \documentclass[fleqn]{unmeethesis}
\usepackage{amsthm,cite,graphicx,,booktabs,lipsum,color,bm,caption,subcaption,soul}
\usepackage{epsfig}
\usepackage[ruled,linesnumbered]{algorithm2e}
\usepackage[cmex10]{amsmath}
\usepackage{pifont,tikz,paralist,multirow,amssymb,stmaryrd}
%\newtheorem{theorem}{Theorem}
\newtheorem{lem}{Lemma}

\begin{document}

\frontmatter


\title{}

\author{ }

\degreesubject{ }

\degree{}

\documenttype{DISSERTATION}

\previousdegrees{
}

\date{December, \thisyear}

\maketitle

\end{dedication}

\begin{acknowledgments}
\end{acknowledgments}
4
  • 1
    unrelated but do not use \usepackage{epsfig} Oct 24, 2022 at 16:15
  • @DavidCarlisle because I have eps figures.
    – Karen
    Oct 24, 2022 at 16:29
  • Where could we obtain the unmeethesis.cls document class? We can't test your code without it.
    – frabjous
    Oct 24, 2022 at 17:27
  • @Karen You can convert eps figures to PDF format and then use them directly. epsfig is obsolete way for including figures.
    – wipet
    Oct 24, 2022 at 17:31

1 Answer 1

0

A command (\clearpage) is missing from the acknowledgements environment definition that prevents the page number from appearing when the botnum option is used.

Try this code with a redefinition of that environment using a patch.

a

% !TeX TS-program = pdflatex

\documentclass[botnum, fleqn]{unmeethesis}  
\usepackage{amsthm,cite,graphicx,,booktabs,lipsum,color,bm,caption,subcaption,soul}
\usepackage{epsfig}
\usepackage[ruled,linesnumbered]{algorithm2e}
\usepackage[cmex10]{amsmath}
\usepackage{pifont,tikz,paralist,multirow,amssymb,stmaryrd}
%\newtheorem{theorem}{Theorem}
\newtheorem{lem}{Lemma}
    
%%******************* added <<<<<<<<<<<<<<<<<
\usepackage{xpatch}
\xapptocmd{\endacknowledgments}{\clearpage}{}{}
%%******************* 
    
\begin{document}    

\frontmatter

\title{}

\author{}

\degreesubject{}

\degree{}

\documenttype{DISSERTATION}

\previousdegrees{}

\date{December, \thisyear}

\maketitle

\begin{dedication}

\end{dedication}

\begin{acknowledgments}
Some text 

\end{acknowledgments}

%
\maketitleabstract %(required even though there's no abstract title anymore)

\begin{abstract}

\clearpage %(required for 1-page abstract)
\end{abstract}

\end{document}
1
  • Thank you so much! It's working!
    – Karen
    Oct 25, 2022 at 2:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .