Yesterday I updated my MikTex 2.9 distribution (Win XP SP3 32 bit) to biblatex 2.1 along with biber 1.1 and some more. (Following packages were updated:

hyperref.tar.lzma...miktex-biber-bin.tar.lzma... miktex-misc.tar.lzma...miktex-texinfo-base.tar.lzma...todonotes.tar.lzma..)

And, suddenly, I was not able to compile my document anymore.

Here is what do and what I get:

  1. delete .aux files.

  2. run pdflatex -synctex=1 -interaction=nonstopmode %.tex -> This works fine. No errors

  3. Run biber. Works, but with a bunch of warnings like:

    WARN - BibTeX subsystem: C:\DOKUME~1\jelzow01\LOKALE~1\Temp\scsg79gtPA\Lit.bib_320.utf8, line 18, warning: 1 characters of junk seen at toplevel

    Still the final message is "Process exited normally".

  4. As at this stage the references are not resolved in the PDF file I run pdftex again:

    pdflatex -synctex=1 -interaction=nonstopmode %.tex

But this time I receive lots of errors (here is an excerpt):

line 1034: Paragraph ended before \name was complete
line 136: Undefined control sequence ...csname newcount\endcsname \scratchcounter
line 136: Missing number, treated as zero ...csname newcount\endcsname \scratchcounter
line 136: Missing = inserted for \ifnum ...csname newcount\endcsname \scratchcounter
line 136: Missing number, treated as zero ...csname newcount\endcsname \scratchcounter
line 136: Undefined control sequence ...csname newcount\endcsname \scratchcounter
line 136: Undefined control sequence ...csname newcount\endcsname \scratchcounter
line 136: Missing number, treated as zero ...csname newcount\endcsname \scratchcounter
line 136: Undefined control sequence ...csname newcount\endcsname \scratchcounter
line 136: You can't use `\xdef' after \advance ...csname newcount\endcsname \scratchcounter

The first one is related to the *.bbl file, the others to the supp-pdf.mkii. They are linked to following lines in log file:

Package biblatex Info: Reference section=2 on input line 10.
Package biblatex Info: Reference section/segment=2/0 on input line 10.
("C:\Programme\MiKTeX 2.9\tex\context\base\supp-pdf.mkii"
[Loading MPS to PDF converter (version 2006.09.02).]
! Undefined control sequence.
<argument> \blx@bbl@data 

Then I found this topic: Biblatex 2.1 bug

There Ulrike Fischer mentioned that the problem might be connected to biblatex 2.1 and should not be present in 2.0. So, I did a downgrade to 2.0. But with no success. The same problem again. I notice the following warning:

Package biblatex Warning: File 'main_diss.bbl' created by wrong version.

Package biblatex Info: ... file 'main_diss.bbl' found.
('path to my bbl file'.bbl
Runaway argument?
{{{hash=3b25bddedd00854b83d926f7f0f709e9}{Tuchin}{T\bibinitperiod }{V\ETC.
! Paragraph ended before \name was complete.
<to be read again> 

Obviously, biber 1.1 created a bbl file for biblatex 2.1. I then wanted to downgrade to biber 1.0. But on the repository


I found only the up to file version uploaded on 2012-Jul-30.

Has anybody an idea what the problem is and how to solve it? Where can I get biber 1.0? Might other packages have influence on this problem?

Any help highly is welcome.

[UPDATE] I also tried to update biblatex to 2.2. Again, with no success.

[UDPATE] SOLUTION of the problem

I guess, I was wrong in blaming biblatex or biber. The problem was located in the *.bib file which I use as my bibliography database. This file is automatically exported from Zotero. Yesterday, I added a short citation but I did not compile (because the update of Miktex was running at that moment). Today, after the update, I noticed the problem described above. Shame on me.

Here is the entry which caused the trouble:

address = {Bellingham, Wash.},
title = {Tissue optics light scattering methods and instruments for medical diagnosis},
isbn = {9780819464330 0819464333 9780819481061  0819481068  9781615837311  1615837310},
url = {http://link.aip.org/link/doi/10.1117/3.684093},
abstract = {This second edition covers the intensive growth in tissue optics--in particular, the field of tissue diagnostics and imaging--that has occurred since 2000. As in the original edition, Part I describes fundamentals and basic research, and Part {II} presents instrumentation and medical applications. The extensive new material includes results on tissue optical property measurements, including polarized light interaction with turbid tissues; an overview of new polarization imaging and spectroscopy techniques, optical computed tomography {(OCT)} developments and applications; updates on controlling tissue optical properties, and the optothermal and optoacoustic interaction of light with tissues; and descriptions of fluorescence, nonlinear spectroscopies, and inelastic light scattering.},
publisher = {{SPIE/International} Society for Optical Engineering},
author = {Tuchin, V. V and {{Society} of Photo-optical Instrumentation Engineers}},
year = {2007},
file = {Tissue Optics | Press Monographs - eBooks:D:\aj\zotero\storage\SXWHA9T7\pm166.html:text/html;Tissue Optics | Press Monographs - eBooks:D:\aj\zotero\storage\Z2A22V52\pm166.html:text/html}

More precisely the trouble is caused by the author field. If I replace

author = {Tuchin, V. V and {{Society} of Photo-optical Instrumentation Engineers}},


author = {Tuchin, V. V},  

everything works fine. As you can see there are some additional brackets {} around the second "author" (the society) which are presumably the reason for the trouble. If I remove the second author everything works.

I suppose that biber parses the author field till it finds the the first closing } and then stops. In this case there is an unbalance in opened and closed brackets. And this makes the trouble.

Thanks to Ulrike Fischer and PLK for the comments. Next time I'll try a minimal example first.

  • 1
    At first you should make sure that there is a bug (and not some error in your document or some problem due to outdated files). So create a new small test document in an empty folder and use this for tests. Also delete the binary cache of biber (see documentation section "Binary Caches"). Aug 8, 2012 at 12:06
  • 2
    There was a problem withn the initial upload of biblatex 2.1 to TexLive. To make a test, you should make sure by getting biblatex 2.1 from SourceForge and using this with biber 1.1. If this does not work, a minimal example with \listfiles at the top of the file would be useful.
    – PLK
    Aug 8, 2012 at 12:47
  • 1
    Well I don't know if it is okay that biber and/or biblatex produce errors because of some braces. Try to make a minimal example so that someone can look into it. Aug 8, 2012 at 13:50
  • 1
    @Dualinity: I create a UTF8 encoded BibTex file (.bib) and use it as the source file for biblatex \addbibresource{.bib}. So, Zotero does not have to export particularly for biblatex.
    – AVJ
    Aug 8, 2012 at 14:35
  • 1
    No news about this ? @misc{citation1, title = {Any title}, author = {{{Foo} bar}}, }, This causes me the same bug. MWE:\documentclass{book} \usepackage[backend=biber]{biblatex} \addbibresource{test.bib} \begin{document} Minimal\cite{citation1}. \end{document} Where author = {{Foo} bar} works well
    – Bjonnh
    Aug 31, 2012 at 16:15


Browse other questions tagged or ask your own question.