I want to write a beamer document in Hebrew.

I noticed that it changes some environments from right-to-left to left-to-right. For example:

% !TEX TS-program = xelatex
% !TEX encoding = UTF-8


\newfontfamily\englishfontsf{Latin Modern Roman}[Script=Latin,Language=English]
\newfontfamily\englishfont{Latin Modern Roman}[Script=Latin,Language=English]
\newfontfamily\HelveticaH{Open Sans Hebrew}[Script=Hebrew]

\begin{frame}{כותרת השקופית}
ישנן שתי אפשרויות:

\item אפשרות מספר אחת
\item אפשרות מספר שתיים

I even added manually the bidi package environment RTL, and the text is still typed in the other direction.

Why is that? Is there a way to solve it?

enter image description here

This question describes just the same situation, but it is way back from 2011, I want to believe that some work on this topic has done by the developers.

The second answer there gives a solution with LuaLaTeX, which I don't know how to use.

1 Answer 1


When i compile your code i don't get this error. Note that in the last update of the bidi package (version 39.5), some problems regarding RTL documents with beamer has been fixed.

Also, polyglossia loads bidi with the RTLdocument option when using Hebrew, so you don't really need to load it nor to start RTL environment by yourself.

Updating to the latest version might solve your problem. For more information about the matter, see the talk Vafa Khalighi gave in TuG 2022.

  • That's right. I now noticed that I have bidi v36.7, 2022/02/18. Updating indeed solves the problem.
    – tush
    Nov 3, 2022 at 8:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .