0

below is my mwe, instead of getting normal it uses bold, and instead of bold it uses bold-italic. The problem seems to be related to the Mandali font since if i use NotoSerifTelugu it is fine. The Mandali normal font can be downloaded on font.google.com. The bold, italic, bold-italic ones on telugufonts.net. I placed the font files in ~/.fonts/Mandali. The normal font file is a .ttf, the three others .otf.

\documentclass[a4paper]{article}

\usepackage{fontsize,fix-cm}
\usepackage{fontspec}

\usepackage{polyglossia}
\setmainlanguage{telugu}
\setotherlanguage{telugu}
\newfontfamily\telugufont{Mandali}[Script=Telugu]
\newcommand{\tel}[1]{\texttelugu{#1}}

\changefontsize{12}
\makeatletter
\let\@normalsize\normalsize
\makeatother
\setlength{\parindent}{0pt}


\begin{document}
అ ఆ ఇ ఈ

\bfseries అ ఆ ఇ ఈ
\end{document}
1
  • You should specify the file names of the bold, italic, bold-italic fonts: \newfontfamily\telugufont{Mandali}[Script=Telugu, BoldFont = ..., ItalicFont= ..., BoldItalicFont = ...] Nov 1, 2022 at 17:04

1 Answer 1

1

I downloaded the fonts and all of them are .otf. Not a real problem, you can find them by name.

I renamed the font files to have no space, and then wrote the test file.

\documentclass[a4paper]{article}

\usepackage{fontsize}
\usepackage{fontspec}

\usepackage{polyglossia}

\setmainlanguage{telugu}

\newfontfamily\telugufont{Mandali}[
  Path=./,
  UprightFont=*Regular.otf,
  ItalicFont=*Italic.otf,
  BoldFont=*Bold.otf,
  BoldItalicFont=*BoldItalic.otf,
  Script=Telugu
]

\changefontsize{12}


\begin{document}

అ ఆ ఇ ఈ

\textbf{అ ఆ ఇ ఈ}

\textit{అ ఆ ఇ ఈ}

\textit{\textbf{అ ఆ ఇ ఈ}}

\end{document}

Change ./ into ~/fonts/ for your setting, but make sure no space is in the file names.

enter image description here

4
  • it's good, i did not know about how to pass these options to \newfontfamily. But since you needed to rename the files, it looks like a workaround. Nov 2, 2022 at 4:18
  • Just by putting the files as they are in ~/.fonts and running the code that i posted, could you tell what you get? Nov 2, 2022 at 4:24
  • @user1850133 I get that the fonts are not found (because of the spaces on the file names).
    – egreg
    Nov 2, 2022 at 7:20
  • can you post somewhere your log file? As for the font file names i did shortcuts instead of renaming, but everytime lualatex is doing luaotfload | db : Reload initiated (formats: otf,ttf,ttc); reason: Font "MandaliRegular.otf" not found. Nov 4, 2022 at 9:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .