12

since I have updated my M1 macbook air to macOS Ventura I am no longer able to use the quicklook feature for my .tex files, in the finder when pressing the space bar on a files it simply prompts me : " The extension com.apple.tips.TipsAppQuicklook-macOS does not implement file previews".

I also tried to manually install a qlgenerator from a third party which should be able to open in preview more uncommon files like redme or markdowns. I tried to check in the terminal with the command qlmanage -m plugins but the com.apple.tips.TipsAppQuicklook doesn't appear in the list that the command yelds.

I have also tried to update all my latex packages thinking that they needed to be up to date with my OS.

I've scavenged the internet but nothings really pops up, I was hoping that someone here would have encountered the same problem and could hint for a solution to this.Thanks in advance to all.

3
  • I have the same problem, and asked a similar question over at apple.stackexchange.com/questions/450357/…. No response yet. Have you solved it? Nov 10, 2022 at 14:29
  • @AndrewJaffe sadly no, I have tried installing various texeditor like BBedit wich is know for providing plugins to various file extensions. I have tried to contact the support of my app of choice to write in tex -wich I payed 25 euros- and asked them if they could have provided me with said plug in. They replied that would be to big of a project and it's not in their road map right now. I sincerely don't know what to do anymore. I have found an app that could might solve this problem is called Peek and it's on the appstore, but I'm not willing to spend anymore money on something that was free.
    – Lorenzo
    Nov 11, 2022 at 15:14
  • Not fixed in 13.1, alas. Dec 13, 2022 at 20:12

4 Answers 4

9

A fairly elegant solution exists: SourceCodeSyntaxHighlight app that handles a large number of file types including .tex. https://github.com/sbarex/SourceCodeSyntaxHighlight

5
  • 1
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review
    – Sebastiano
    Dec 4, 2022 at 20:01
  • Thanks for the tip.
    – Bill
    Dec 4, 2022 at 20:57
  • that seems to resolve my problem, thanks from the bottom of my heart <3
    – Lorenzo
    Dec 5, 2022 at 20:16
  • 1
    How can we be sure that this app contains no viruses/malware/etc.? Apr 13, 2023 at 0:49
  • @xFioraMstr18: As with any third-party software larger than a short shell-script, it’s near-impossible to be absolutely sure. But it’s open-source, with code free to read right there on Github — so at least if you’re willing to compile it from source, that gives about as much assurance of security as anything can. (Not meaning that you need to check the whole source code yourself — the point is that since anyone can check it, any time, the author is making themself transparently accountable, and so effectively guaranteeing not to include anything malicious.) Mar 17 at 12:31
3

(The following is also posted here.)

First the app at https://github.com/sbarex/SourceCodeSyntaxHighlight mentioned by @bill in that answer seems to fix it for me by explicitly providing quicklook for many types of text source files (perhaps too many!)…

However, after installing it and then uninstalling it as a test, the “TipsAppQuicklook” message seems to go away for some — but not all! — file types, but still without actually showing the preview window.

Having noticed this behaviour after deleting the syntax highlighter app, I tried some more deletions. First, I deleted TextMate. Still no preview, but the button changed from "Open with TextMate" to "Open with TeXShop". So I deleted TeXShop. And then... it worked (i.e., unhighlighted full window preview with an "Open with Bbedit" button)!

But I still wanted TextMate, so I reinstalled it (and TeXShop, although I really don't use it) and... it still worked! It still had "Open with BBedit" but I was able to change that with the "Get Info" dialog. It's not perfect: no syntax highlighting, and css files still don't show a preview, and it seems to be brittle regarding opening with BBEdit vs TextMate, which sometimes causes it revert to the bad behaviour, but it might be an adequate solution (though I may actually go back to the new syntax-highlight app).

Clearly there is some dependence of all of this on the order of installation of the applications and how they register their capabilities which can result in clashes. I wonder if it's documented anywhere and if there are less sledgehammery ways to change how it works....

0

I encountered this problem on my new M1 iMac running Ventura. I tried the other solutions and discovered that certain other files could not be previewed. I finally found an app call Peek on the Mac App Store and it seems to work perfectly for me. It is not free, but it is also not expensive. It lets me preview files with no extension, like platexmkrc, which the other solution would not do for some reason.

https://apps.apple.com/us/app/peek-a-quick-look-extension/id1554235898?mt=12

-2

You’re probably going to want to ask this on https://apple.stackexchange.com

I would start by control-clicking on the file (or right clicking if you prefer) to get the menu and selecting Get Info. Under Open with: (near the bottom of the window that comes up), it should show what app the default opener for .tex files is. If it’s not TeXShop or your preferred TeX editor, try selecting that, then clicking the Change All… button and see if that restores Quicklook. My best guess is that there’s an app on M1 MacBooks which is claiming ownership of files with a .tex extension.

2
  • I'd be interested to know how this turns out. For the longest time, under iOS, I could not preview .tex files in Dropbox. I submitted a query to Dropbox about this (dropbox.zendesk.com/hc/requests/8468155) and was told, "From our investigation it seems that the file in question is unable to be previewed due to the fact we preview these files using Apple's quick look which does not currently have this ability.[to view files with a .TeX extension]" That was November, 2018.
    – sgmoye
    Nov 3, 2022 at 11:12
  • 2
    The funny thing is that with my previous MacOS version .tex files could be previewed with quicklook but suddenly not anymore. I also tried changing to texshop as it should have been my default app to open .tex files, also tried to quit and reopen the Finder via a thirdparty app, but nothing changes still
    – Lorenzo
    Nov 3, 2022 at 15:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .