1

I've reinstalled windows and now trying to compile the same .tex document that was working perfectly before (TexStudio + MikTex). Unfortunately, I always end up with an error that seems to be related to a missing package.

\usepackage{pdflscape}

The error is:

File `pdflscape.sty' not found. \usepackage

However, if I search for pdflscape in MikTex packages I see it. The database is refreshed, and packages are updated (in user mode). enter image description here

Any idea what might cause the error? And how to solve it without manual package installation via the console.

P.S. If I manually install pdflscape via MikTex console, I'll get more errors that all seem to be related to missing packages. I suspect all those errors have the same root, so I'd like to focus on solving this issue without manual package installation.

11
  • does miktex say that it is installed? Do you have pdflscape.sty somewhere? Commented Nov 11, 2022 at 15:32
  • @UlrikeFischer I can locate the package in MikTex console. So it seems that it's aware of the package's existence. However, it is not installed. Even though TexStudio attempted to request it
    – pintor
    Commented Nov 11, 2022 at 15:37
  • Well then install if with the miktex console. Commented Nov 11, 2022 at 15:44
  • @UlrikeFischer tried it already but run into more weird errors with tikz-uml package: "Extra \or. \end{umlcallself}", which I cannot resolve (latest .sty is in the project, all listed in the tikz-uml doc packages are installed, but nothing helps). My only explanation is that something is wrong with the FNDB, so it cannot find all dependencies and hence cannot build tikz-uml. I hope that if can solve pdflscape error without manual installation, then tkiz-uml will work too.
    – pintor
    Commented Nov 11, 2022 at 15:51
  • pdflscape has nothing to do with tikz. If pdflscape is not there you have to install it with the miktex console. LaTeX can not create it out of thin air. Once it is installed you can handle the next error. Commented Nov 11, 2022 at 15:57

1 Answer 1

1

There was a bug in the pdflscape packaging https://github.com/MiKTeX/miktex-packaging/issues/303. But the last update repaired that.

You should now see this in the package list:

enter image description here

1
  • Thank you, now it works! The package was installed on the fly
    – pintor
    Commented Nov 18, 2022 at 13:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .