0

I have following MWE:

% -------------------------------------------------------
\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[latin1]{inputenc}
\usepackage{hyperref}
\usepackage{enumitem,enumitem-zref}

\begin{document}

\begin{enumerate}[start=34,label=(\arabic*),name=thelist]
\item stuff
\item more stuff \label{more stuff}
\item yet more
\end{enumerate}

The is \refitem{thelist,35} or \refitem{thelist{35}}
and this is also \refitem{more stuff}


\end{document}\endinput
% -----------------------------------------------------

After compiling I have following errors:

Undefined control sequence.
\zen@item@comma ->\begingroup \c@zenidx 
Undefined control sequence.
<argument> \ifcsname Z@R@zen>\the \c@zenidx 
You can't use `\endcsname' after \the.
<argument> ...e Z@R@zen>\the \c@zenidx \endcsname 
Missing \endcsname inserted.
<to be read again> 
...
Package zref: Property `zen@anchor,zen@currentlabelname' does not exist.
Package enumitem: name undefined.

I have enumitem and enumitem-zref packages installed. Is this bug?

9
  • unrelated but are you sure you want \usepackage[latin1]{inputenc} ? for example all code posted here is in utf-8 not latin1 Commented Nov 12, 2022 at 9:20
  • The first error is ! Undefined control sequence. <recently read> \globcount the errors you show are essentially spurious followon if you scroll past the error Commented Nov 12, 2022 at 9:22
  • enumitem-zref is falling over changes made in 2015 so I guess it is unmaintained \let\globcount\newcount gets past the errors you show but it then triggers errors in zref what is your actual use case here are you sure you need this package? Commented Nov 12, 2022 at 9:34
  • Package zref: Property `zen@anchor,zen@currentlabelname' does not exist is due to a change made in zref in 2010, zref has the comment % Between 2010/04/19 v2.13 and 2010/10/22 v2.19 a comma separated list of properties could be used as argument \meta{propname}. ... So enumitem-zref worked for 6 months, 12 years ago, but has not worked since. Commented Nov 12, 2022 at 9:55
  • As David wrote the package is broken since a long time. How did you find it? Commented Nov 12, 2022 at 10:11

0

You must log in to answer this question.

Browse other questions tagged .