I recently downloaded Apple Ventura and with my great surprise I'm not longer able to open Lyx. I tried to uninstall and reinstall, to open it despite it's not a Mac app, etc but with no results. How can I solve this issue? The app doesn't open at all...

Thanks a lot!

  • Which TeX distribution to you employ? MacTeX2022? If so, when did you last update it?
    – Mico
    Nov 16, 2022 at 0:10
  • Thanks for your answer! I use Miktex console 2.9.7364. From my understanding MacTeX2022 doesn't run on MacOS Ventura. Nov 16, 2022 at 0:43
  • 1
    @JoshuaMollner MacTeX works just fine on Ventura (heavily tested here, both on Intel and M1 processors). However, I have no experience with LyX.
    – Miyase
    Nov 16, 2022 at 1:29
  • @Miyase, thank you! I just downloaded it and now the problem seems to be I cannot update Live Tex Utility to the 2022. Despite that, I still find weird that Lyx doesn't even open. The Tex package should matter for compiling pdf to the best of my knowledge. Nov 16, 2022 at 1:40
  • I can confirm @Miyase's claim that MacTeX2022 runs just fine on Ventura on my systems -- a 2022 MacBook M2 Air and a 2021 MacBook M1Max Pro, in case it matters.
    – Mico
    Nov 16, 2022 at 5:07

2 Answers 2


Don't open the application with a double click. Click it while pressing the Control-key instead.

  • It doesn't work that way either Nov 17, 2022 at 19:11

Did you allow LyX to run in the security settings of MacOS? You will first need to clear LyX there in order to launch it.

Unfortunately, in Ventura the old Preferences dialog has been replaced by an iOS-style two-column window, but the functionality is the same.

  1. Install LyX, then try to launch it by double-clicking.
  2. The Finder will complain about LyX coming from an unknown developer.
  3. Now you need to change to the Preferences dialog, scroll down to the security settings (left column) and then past all the app settings (right column) to the section where you have the chance to override the settings which block LyX. Confirm with your password.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .