1

I am new to LaTex writing a research paper. I am using MikTex and VSCode

I am using \usepackage[backend=biber, style=apa]{biblatex}. This correctly generates references & bibliography on my windows computer, but when I work on my MacOS M1 laptop, it does not.

I have already updated all packages to the latest version. I have also tried adding the code below in settings.json of VSCode.

{
    "name": "biber",
    "command": "biber",
    "args": [
        "%DOCFILE%"
    ]
}

However, running PDFLatex-->biber-->PDFLatex x2 does not work either.

Is there anyway that my installation of MikTex/VSCode/Biber is incorrect for MacOS?

10
  • 1
    Welcome to TeX.SE!
    – Mensch
    Nov 17 at 17:48
  • 4
    I wouldn't use miktex on a mac. Most mac user will use texlive or mactex (the later uses texlive internally) -- this is much better tested. Nov 17 at 17:50
  • 4
    Does it work if you compile from the command line? Nov 17 at 17:52
  • @samcarter_is_at_topanswers.xyz I work with a Mac laptop and a Windows desktop. So I sync the same files between the 2 computers, so I thought I was forced to use MikTex for both. Can I run MacTex on my Mac, and MiKtex on my PC, and still have the files sync together? Does not work if compiled from command line.
    – Solarrixs
    Nov 18 at 1:39
  • There were some initial hiccups with Biber on M1, but as far as I understand the binary should work now (see e.g. github.com/plk/biber/issues/433). I'm assuming, however, that the vast majority of Mac users use MacTeX or TeX live, so it is entirely possible that there has been no feedback from MikTeX users yet. Maybe MikTeX does not have the newest binaries from CTAN? What exactly happens when you try to run biber --version or biber <yourfile> form the command line? Do you get error messages?
    – moewe
    Nov 18 at 6:41

0

Browse other questions tagged or ask your own question.