See answer: personal issue with the path not being the correct one.

When running lualatex I get the following error message:

Error producing PDF.
! LaTeX3 Error: Mismatched LaTeX support files detected.
(LaTeX3)        Loading 'expl3.sty' aborted!
(LaTeX3)        The L3 programming layer in the LaTeX format
(LaTeX3)        is dated 2022-04-10, but in your TeX tree the files require
(LaTeX3)        at least 2022-11-02.

I already checked the answers for that question (especially this one), but none of it worked, I still get the same error message.

When I run

  • kpsewhich --all --engine=pdftex pdflatex.fmt I get /home/(user)/.texlive2022/texmf-var/web2c/pdftex/pdflatex.fmt

  • kpsewhich --all --engine=luahbtex lualatex.fmt I get /usr/local/texlive/2022/texmf-var/web2c/luahbtex/lualatex.fmt

  • kpsewhich --all --engine=xetex xelatex.fmt I get /usr/local/texlive/2022/texmf-var/web2c/xetex/xelatex.fmt

And if I run it with the -dev extension like pdflatex-dev.fmt I get the exact same output with files having the -dev extension.

That seems ok to me, so I do not what is wrong.

I also ran sudo fmtutil-sys --all and I don’t seem to have an issue.

I am running on that if it is relevant:

$ tlmgr version 
tlmgr revision 63068 (2022-04-18 07:58:07 +0200)
tlmgr using installation: /usr/local/texlive/2022
TeX Live (https://tug.org/texlive) version 2022

  • 1
    remove /home/(user)/.texlive2022/texmf-var/ so you use your updated system formats not old ones you made in your account previously Nov 25, 2022 at 0:12
  • deleting those files is also what is suggested in the answer that you link to Nov 25, 2022 at 0:59
  • 1
    unless you have fixed your sudo path since your last question sudo fmtutil-sys --all will be using the wrong fmtutil-sys, don't use sudo or use the full path Nov 25, 2022 at 1:03
  • Make sense. Thanks a lot!
    – Louis
    Nov 25, 2022 at 1:10

1 Answer 1


based on David Carlisle comments:

  • Delete /home/(user)/.texlive2022/texmf-var/
  • And because I haven’t set the correct path for sudo fmtutil-sys, just used the ablosute path sudo /usr/local/texlive/2022/bin/x86_64-linux/fmtutil-sys --all.

That worked.

Not the answer you're looking for? Browse other questions tagged .