When I load the package lwarp with the command \usepackage{lwarp} and I press F1 (or compile/build) I get the error with the file


at the line 33. Within that file, above line 33 is the command: \RequirePackage{ifptex} So I thought the problem should be that missing package, and indeed the error message says:

! LaTeX Error: File `ifptex.sty' not found.Type X to quit or to proceed,or enter new name. (Default extension: sty)Enter file name:! Emergency stop. flag __ ^^M

So I searched for that package and found it here ifptex.sty. Now I created a directory for that package: /usr/share/texlive/texmf-dist/tex/latex/ifptex/ and put there the package, but that doesn't fix the problem (I get the same message). I tried to put the ifptex package near the location of the other required packages (iftex and ifpdf) i.e.


I created a folder at generic/ifptex but didn't work, I put the ifptex.sty file in the folder iftex but also didn't work.

My question is, why is this not working? How can I install the package properly? The instruction in the readme file says for installation:

In a system compliant to TDS 1.1, move the files as follows: *.sty → $TEXMF/tex/generic/ifptex

Which I have done so far, but I get the same error message.

I'm using TeXMaker 5.0.3 (compiled with Qt 5.15.3) with TeXlive in Ubuntu 22.04.1 LTS.

  • 1
    Try running mktexlsr maybe? Nov 26, 2022 at 8:26
  • 2
    the files under usr share are managed by apt you should not add files there by hand just install texlive-full or a suitable subset via apt Nov 26, 2022 at 8:43
  • @DavidCarlisle I have texlive-full. Nov 26, 2022 at 21:22
  • @JoséMarín then if your texlive is new enough to have lwarp at all then lwarp.sty should be at texmf-dist/tex/latex/lwarp/lwarp.sty Nov 26, 2022 at 21:25
  • @DavidCarlisle Yes it is and is not working. Nov 26, 2022 at 21:31

1 Answer 1


I followed the answer given here: How do I install an individual package on a Linux system? by @Loop Space using method 1. A brief summary here:

I typed in the terminal:

which tlmgr

to know where is tlmgr:


then I run the command:

sudo /usr/local/texlive/2022/bin/x86_64-linux/tlmgr install ifptex

and that solves my problem. Thank you.

Edit and comments clarification

This edit is because at first I made an error, I wrote a wrong solution, I spot the error thanks to @David Carlisle. I got confused, but now I think this is really the answer that solved my problem.


Well I don't know if this is an update, but there is another way to install individual packages using the (Synaptic) Package Manager. First thing you need to know is the name of the package where the package is, I will explain below. For example if I got an error with \usepackage{IEEEtrantools} then I have to install the ieeetran LaTeX package, but in what debian package is that LaTeX package? To know that use the following command:

apt-cache search ieeetran

Or in general:

apt-cache search <name of the package>

That will print the name you are looking for. In this hypothetical case: texlive-publishers. Next just install it via (Synaptic) Package Manager

  • 1
    no sorry this answer is completely misleading. sudo apt-get install will have installed files in the system tex under /usr/share it will have done nothing to the texlive installed under /usr/local which is managed by tlmgr not apt Nov 26, 2022 at 23:40
  • This solves my problem, now lwarp package is working fine (because ifptex was installed this way). Nov 26, 2022 at 23:44
  • 1
    Glad you have got it working but you are using the debian system tex, not the one you installed from tug, That is not necessarily a bad thing. Nov 26, 2022 at 23:46
  • @DavidCarlisle I think I see your point. I edited the answer to fix that. Nov 27, 2022 at 0:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .