0

I would like to change the empty page style to a style with a header, working in LyX using the Memoir Document Class. But I can't get it working.

I have tried various changes in the LyX Document Settings: Page Layout > Page style: headings, as well as Page Layout > Page style: Default.

Also tried LaTeX Preamble > \pagestyle{headings} and combinations of the above, but it did not have any effect. The page style appears to stay the same as empty.

What am I missing?

Uning LyX version 2.3.6.2.

2
  • 1
    Hello, I could not reproduce this problem using LyX 2.3.6.1. Note that the page style is not empty by default and you should see headers with the default settings. Could you post a MWE? LyX is a text file so you can open it with any text editor and post his code here.
    – Udi Fogiel
    Nov 29, 2022 at 13:53
  • @udi fogiel, thanks for your reply. I'll try to make a MWE. Nov 29, 2022 at 20:07

1 Answer 1

0

As suggested by Udi Fogiel, I developed a Minimal Working Example (still substantial due to Memoir), and I found my mistake.

My Title page, Preface, etc. are based on the very nice book Self-publishing with LYX, by Alan L Tyree. Following his book, the \frontmatter section contains a \pagestyle{plain} command. This command overwrites the settings in the LyX Document settings.

Changing this to \pagestyle{headings} solved my problem.

2
  • 1
    Glad you solved the problem :). is there a free pdf of the book you mentioned? I saw in the lyx wiki there is, but could not find it. By the way, you can accept your own answer and you probably should, this way it will be marked as solved.
    – Udi Fogiel
    Dec 1, 2022 at 10:59
  • Somehow I got a free PDF through the lyx website. But the link doesn't work anymore. Too bad. Dec 1, 2022 at 15:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .