1

Having this in TeX:

\documentclass{article}
\usepackage[ngerman]{babel}
\usepackage{csquotes}

\begin{document}
"Error"\\
"Server"
\end{document}

compiles to

Ërror"
SServer"

I need to be able to use the " ASCII sign in the text of a latex document. I cannot use any kind of macro.

Specific: I want to terminate the babel shorthand command, that is converting the " sign to an Ë

Expected Result:

"Error"
"Server"

EDIT: Clarified ngerman and Goal

EDIT2: clarified usage of the " sign

2
  • 3
    Do you happen to load the babel package? If so, with which language option? Please also clarify what "Tried csquotes, but no luck" might entail. E.g., did you try to employ the package's \enquote macro? If so, with which options did you load the csquotes package?
    – Mico
    Commented Dec 5, 2022 at 19:07
  • My editor won't allow me to enter " at all It used to automatically generate `` and ''. Now it converts them to "` and "'. Commented Dec 5, 2022 at 20:44

1 Answer 1

2

(updated the answer after learning that the OP wants to disable babel shorthands)

You need to change

\usepackage[ngerman]{babel}

to

\usepackage[shorthands=off,ngerman]{babel}

in order to diasble babel shorthands.

5
  • Thank you, is it possible to deactivate this behaviour? I am templating the document content and cannot control what is coming in, so the " sign must be possible without conversion.
    – flymg
    Commented Dec 5, 2022 at 19:32
  • 1
    @flymg - Please clarify what you mean by "deactivate this behavior". E.g., do you wish to terminate all babel shorthand commands? Or just some of the shorthands? Please be specific. Is something stopping you from writing "{}Error" and "{}Server"? Incidentally, why do you apparently insist on using dumb quotation marks?
    – Mico
    Commented Dec 5, 2022 at 19:56
  • I need to be able to use the " ASCII sign in the text of a latex document. I cannot use any kind of macro. I updated the question. I want to terminate the babel shorthand command, that is converting the " sign to an Ë
    – flymg
    Commented Dec 5, 2022 at 20:01
  • 1
    @flymg - Please see my updated answer.
    – Mico
    Commented Dec 5, 2022 at 20:11
  • perfect, thank you
    – flymg
    Commented Dec 5, 2022 at 20:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .