I have installed the recent version of MiKTeX on OS Windows 11, last update: 12/02/2022, last week and I have a problem. It had never happened to me before. If I write this minimal working example like this


I receive always the following message:

This is pdfTeX, Version 3.141592653-2.6-1.40.24 (MiKTeX 22.11.25) (preloaded format=pdflatex.fmt)
 \write18 enabled.
entering extended mode
(C:/Users/sebys/OneDrive/Desktop/new question/Test3.tex
LaTeX2e <2022-11-01> patch level 1
L3 programming layer <2022-11-02>
Document Class: article 2022/07/02 v1.4n Standard LaTeX document class
For additional information on amsmath, use the `?' option.

tex.def) (C:/Users/sebys/OneDrive/Desktop/new question\Test3.aux
! Not loaded.
\selectlanguage ...ing it}\errmessage {Not loaded}
l.2 \selectlanguage

.aux file.

\selectlanguage *{spanish}
\@writefile{toc}{\selectlanguage *{spanish}}
\gdef \@abspage@last{1}

What has happened?

Related old question: Package babel Error: You haven't loaded the option spanish yet. Deleting .aux does not work

How should it be solved?

  • 1
    I can't reproduce your problem (I tested your MWE as is in new file), however, you not load babel.
    – Zarko
    Dec 7, 2022 at 21:14
  • 2
    show the complete log? Dec 7, 2022 at 21:15
  • 2
    Presumably the minimal example is too minimal and the problem only occurred in your tests only because of commands left over from previous runs in the temporary files (.aux or possibly one of the .lo... files). Does the MWE reproduce the error for you when you run it in a new, empty folder?
    – moewe
    Dec 7, 2022 at 21:22
  • 1
    a log is always generated, but here simply delete the .aux Dec 7, 2022 at 21:43
  • 6
    you probably compiled something using polyglossia earlier. Simply delete the aux and recompile. Dec 7, 2022 at 21:47


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy