0

I have included the package to indent the first line of each paragraph but it is not working in my paper. Any advice would be appreciated.

\documentclass[letterpaper,hidelinks,12pt]{article}

\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage[nottoc]{tocbibind}
\usepackage{breakcites}
\usepackage{float}

%Import the natbib package and sets a bibliography  and citation styles
\usepackage{natbib}
\bibliographystyle{abbrvnat}
\setcitestyle{authoryear,open={(},close={)}} %Citation-related commands
\usepackage{etoolbox}
\AtBeginEnvironment{thebibliography}{\linespread{1}\selectfont}

\usepackage[colorlinks=true, allcolors=blue]{hyperref}
\usepackage{amssymb, amsfonts, amsmath}
\usepackage{bm}
\usepackage[margin=1in]{geometry} % full-width
    \topskip        =   20pt
    \parskip        =   10pt
    \parindent      =   0 pt
    \baselineskip   =   15pt



\usepackage{setspace}               % line spacing
    \onehalfspacing
\usepackage{adjustbox}              % resizing
\usepackage{caption}                % to reset the cations etc 
\usepackage{rotating}               % for the sidewaystable
\usepackage{booktabs}               % neatly formatting lines
\usepackage{dcolumn}                % aligning decimals
    \newcolumntype{d}[1]{D{.}{.}{#1}}
\usepackage{natbib}                 % bibliography
%% \bibliographystyle{plainnat}

\newcommand{\sym}[1]{\rlap{#1}} % for the stars


\usepackage{graphicx}
\usepackage{adjustbox}
\usepackage{graphics}
\usepackage{subcaption}
\usepackage{lscape}
\usepackage{amsmath}
\usepackage{mwe}
\usepackage{ragged2e}
\usepackage{setspace}
\usepackage{chngcntr}
\usepackage{amsmath}
\usepackage{setspace}
\usepackage{autobreak}
\usepackage{amsmath}
\usepackage{mathtools}
\usepackage{indentfirst}
0

1 Answer 1

1

A more reasonable example file would be

\documentclass{article}

    \topskip        =   20pt
    \parskip        =   10pt
    \parindent      =   0 pt
    \baselineskip   =   15pt

\begin{document}

One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 


One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 
\end{document}

Producing

enter image description here

if you remove the settings of \parskip and \parindent you will obtain the default indented layout

\documentclass{article}

    \topskip        =   20pt
%    \parskip        =   10pt
%    \parindent      =   0 pt
    \baselineskip   =   15pt

\begin{document}

One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 


One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 
One two three. One two three. One two three. 
\end{document}

enter image description here

In general, avoid randomly copying lines in to the preamble. Always start from an empty preamble and just add packages when needed. Once you get an over large preamble with lots of unusable code such as repeated packages, it makes it hard to spot the code that is affecting the document.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .