I've this problem using moderncv. I'm using multibib and the first bibliography entry is:

  author         = "Aad, Georges and others",
  title          = "{Measurement of the inclusive isolated prompt photon cross-section in pp collisions at sqrt(s)= 7 TeV using 35 pb-1 of ATLAS data}",
  collaboration  = "ATLAS Collaboration",
  journal        = "Phys.Lett.",
  volume         = "B706",
  pages          = "150-167",
  doi            = "10.1016/j.physletb.2011.11.010",
  year           = "2011",
  eprint         = "1108.0253",
  archivePrefix  = "arXiv",
  primaryClass   = "hep-ex",
  reportNumber   = "CERN-PH-EP-2011-115",
  SLACcitation   = "%%CITATION = ARXIV:1108.0253;%%",

and it is translated by bibtex to:

{ATLAS Collaboration} Collaboration, G.~Aad et al., {\em {Measurement of the
  inclusive isolated prompt photon cross-section in pp collisions at sqrt(s)= 7
  TeV using 35 pb-1 of ATLAS data}\/},
  \href{http://dx.doi.org/10.1016/j.physletb.2011.11.010}{Phys.Lett. {\bf B706}
  (2011)  150--167},
\href{http://arxiv.org/abs/1108.0253}{{\tt arXiv:1108.0253 [hep-ex]}}.
%%CITATION = ARXIV:1108.0253;%%.

When I run pdflatex I get:

[4]) (./pub.bbl
! Undefined control sequence.
<argument> \Hy@safe@activesfalse Phys.Lett. {\bf 
                                                 B706} (2011) 150--167
l.8   (2011)  150--167}

what's the problem? I used the same .bib file without moderncv and I haven't such problems.

My preample looks like this:






\newcites{conf}{Conferences and talks}
\newcites{confnote}{Selected conference and public notes}
\newcites{intnote}{Selected internal notes}
  • What does the rest of your preamble look like? \bf was deprecated with LaTeX2e, but it should still be usable. – AstroPig7 Aug 13 '12 at 21:18

Support for the old commands \bf, \rm, etc. is generally provided by the document class. For example, lines 579-587 of report.cls contain the following


This is missing from moderncv.cls. Try adding the above to the preamble of your document. In this particular case you could just add the lines concerning \bf, \em and \tt, but it's probably worth adding them all, just to be sure the problem won't occur again.

  • thank you, I've modified the bst with \tt->\texttt and \bf -> \textbt, now it works – wiso Aug 13 '12 at 21:39
  • Be careful! \texttt and the like apply to the next object only, whereas the old commands apply until the end of the current group. So, in your example, only the 'B' in 'B706' will be in bold if you simply change \bf to \textbf. – Ian Thompson Aug 13 '12 at 21:45

\bf is apparently not defined in some modern implementations of LaTeX. I reproduced this issue with XeLaTeX and the following MWE:

Test \bf test

I was using XeLaTeX 0.9998 and MiKTeX 2.9. moderncv was last updated in 2007, so this is likely just the march of time leaving behind an unmaintained package.

  • Ah, I based my comment on the date given in the README. Regardless, \bf does not work in my copy of XeLaTeX, and I see Ian Thompson has explained why. – AstroPig7 Aug 13 '12 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.