2

I want

  • each "first-time-used" glossary entry to appear in the footnote with its description and
  • each "used" entry (the short term) being linked to the entry with its description in the glossary.

I achieved the first point, but the second one is not always working properly. I have to "play" with the loading order of "hyperref" and "glossaries" to make it work.

The problem is, that the links only work if the package "hyperref" is loaded before the package "glossaries". I read everywhere, that hyperref must be loaded as the last package, so I am not sure, if I did this right.

Does there exist a better way to achieve my requirements?

I am using miktex 2.9 and my document type is "scrreprt".

This is the way how I refer to the glossaries-package:

\usepackage
[   nonumberlist,
    toc,
    footnote,
    acronymlists={main}
]{glossaries}                       
\newglossary[slg]{symbolslist}{syi}{syg}{Symbolverzeichnis} 
\renewcommand*{\glspostdescription}{} 
\makeglossaries

\def\theglossary{%
    \@ifundefined{chapter}{\section}{\chapter}{\nomname}%
    \nompreamble
    \list{}{%
    \labelwidth\nom@tempdim
}}

\printglossary[style=altlist,title=Glossar]

This is one of my glossary-entries:

\newglossaryentry{gloss:ACM}{name=ACM, first={Adaptive Case Management (ACM)}, description={\textbf{A}daptive \textbf{C}ase \textbf{M}anagement tries to... (my description).}}

This is how I refer to the hyperref-package:

\usepackage[
    pdfpagelabels,
    bookmarksopen,
    pdfstartview={FitV},
    plainpages=false,
    breaklinks=true,
    linkbordercolor={1 1 1},
    citebordercolor={1 1 1},
    urlbordercolor={1 1 1}
]{hyperref} 

Thanks in advance for hints and ideas,
Timo

5
  • glossaries is one of the packages that must be loaded after hyperref, see tex.stackexchange.com/questions/1863/…. Please give a compilable example showing what doesn't work properly.
    – lockstep
    Commented Aug 14, 2012 at 9:20
  • Thank you very much for this information! It's a good felling to know that I have done it the right way. Like I described: the problem is not always present. The next time it shows up, I will create a MWE with the given effect. (Though I hope, that it will never appear again...) Commented Aug 14, 2012 at 10:04
  • Good to hear that your document shows no problematic behaviour right now. Note that your question is likely to be closed as "too localized" at some point if you don't provide a MWE.
    – lockstep
    Commented Aug 14, 2012 at 10:09
  • Please add a minimal working example (MWE) that illustrates your problem. Commented Aug 19, 2012 at 9:59
  • @MarcoDaniel: This problem seems to be solved. As I have written, the problem does not occure in a deterministic way. At the moment I do not have any problems. With this question I wanted to find out if my usage of hyperref, footnotes and parnotes is somehow wrong. For I have found out that this setting is ok, I am fine to mark this question as "answered", but I have not found an option to do this. Commented Aug 21, 2012 at 9:41

0

Browse other questions tagged .