I am having problems inserting nomenclature entries using Lyx. I enter the symbol and description, press OK, and the nomenclature entry is not made ( ie no box Nom: ...) [no error messages]. I haven't worked out what triggers this ( ie sometimes insertion works, sometimes doesn't)...Its very frustrating.
I am mainly dealing with mathematical symbols so I tend to (try to) insert in formula or after formula... I feel that the problem has to do with where I place the insertion, but I haven't worked it out. Similarly I haven't got a little test file to demonstrate it

  • Please provide a MWE (minimal working example) and show us how you tried to use the nomenclature. Then we can help you out. This way it is hard to see what you are doing. Anyway, this link might be helpful. – Timo Paschke Aug 14 '12 at 11:12
  • I haven't been able to generate a MWE ( as I said). The problem is "random" - so I was hoping someone else had actually come across it – sean Aug 15 '12 at 13:10

OK well I have "resolved" the issue. If an element of a formula is selected when you press OK, then no nomenclature inset is created/modified. if you have text selected (outside formula inset) then the text is overwritten by the nomenclature inset.

I tend to copy paste my symbols into the nomenclature box from my document and this leads to the symbols being selected (in the formula inset). If you unselect before pressing ok in nomenclature inset then everything works ok.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.