6

When using \rputwith the rotation parameter it seems to rotate my whole document if the rotated text is longer then the non-rotated text.

See this minimal example:

\documentclass[dvips]{article}
\usepackage{pst-all}
\begin{document}
\pagestyle{empty}
\fontfamily{phv}\selectfont
\psset{xunit=1cm,yunit=1cm,runit=1cm}
\psset{linewidth=1pt}
\begin{pspicture}(16,11)
    \psframe[fillstyle=solid](16,11)

    % Koordinaten Unten
    \psline[linewidth=2pt]{<->}(1,0.5)(15,0.5)
    \rput(8,0.2){\textbf{HText1}}
    \rput[l](3,0.7){HText2}
    \rput[r](13,0.7){HText3}

    % Koordinaten Seite
    \psline[linewidth=2pt]{<->}(0.5,1)(0.5,10)
    \rput[l]{90}(0.75,2){VText1}
    \rput[r]{90}(0.75,9){VText2}
    %\rput{90}(0.25,5.5){\textbf{VText3}} % This does the right thing
    \rput{90}(0.25,5.5){\textbf{VText3 Rotate}} % This leads to rotation
\end{pspicture}
\end{document}

So if the short text (VText3) is printed, the document has the right rotation. If the long text (VText3 Rotate) is printed, the document rotates.

Is there a way to shut this down?

  • You can also invoke GhostScript directly: gswin64c -dAutoRotatePages=/None -sDEVICE=pdfwrite -o outputfile.pdf inputfile.ps and no need to change = to # for this direct method. If you use GhostScript 32 bit then replace gswin64c with gswin32c. – kiss my armpit Aug 15 '12 at 5:54
  • that ignores the compatibility setting in ps2pdf – user2478 Aug 15 '12 at 8:40
7

it is a problem with GhostScript which is too clever here and thought that it should rotate the page. Use

ps2pdf -dAutoRotatePages=/None <file.ps>

or for Windows:

ps2pdf -dAutoRotatePages#/None <file.ps>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.