I've struggled with a new computer and miktex for sometime. I asked this question before and thought I had it resolved (saw a green hyper link box in the pdf and assumed all was good) but did not. (See question: references not printing). I have some more information and hopefully can get this solved.

I stopped using WinEdt and can replicate the problem in MikTeX.

Here is the code I'm running:

\usepackage[style=apa, backend=biber, bibencoding=latin1]{biblatex}

\usepackage{microtype}  %disable ligitures
\DisableLigatures{encoding = *, family = *}



 %\numberwithin{equation}{subsection} %changes labeling of equations

\setlength{\parindent}{1 em}


\title{Teacher Metacognition: The Intentionality of Teacher Led Speech}
\shorttitle{Intentionality of Teacher Led Speech}
\author{Tyler Rinker\\University at Buffalo\\Department of Learning and Instruction}

\authornote{Theories of Language \& Literacy}%LAI 687 -


%\hspace{.5in}Usually a paper has an introduction but there is no heading for the introduction.  That's what you've got here, an introduction with no heading.  %Not pretty but it pleases the APA.

I want this to work \cite{Nagy1985}

\clearpage %This forces a page break


I When I run this with both biber and bibtex as the backend. Here is a zip file with my bib file, tex file and the two pdfs that out put using biber and bibtex as backend.


Now for some information. If I run it with bibtex as the backend the references never print and the in text citation appears as the bibtex citation key in bold. Ok if I switch to biber as the back end the references still don't print but the in text citation appears correct (green hyper link box around it and the year) but when I click on it it takes me to my cover page as there is no reference section to go to.

If I run the same pdfLatex thing again (the green play button in texworks labeled Typeset if you hover over it) the green intext hyper reference boxes go away and the in text citation is not a date any more but the bold BibTex key instead. The only way to get it back to being green hyper box with year is to switch to bibtex as backend, run it, and the switch back to biber as the back end.

Here is the console out put:

Command Line:   bibtex.exe "theories"
Startup Folder: C:\Users\trinker\Desktop\PhD Program\Indep. Study\lit_review_articles_explicit_talk\paper

This is BibTeX, Version 0.99d (MiKTeX 2.9)
The top-level auxiliary file: theories.aux
The style file: biblatex.bst
Database file #1: theories-blx.bib
Database file #2: explicit.bib
Biblatex version: 2.1

Command Line:   texify.exe --pdf --tex-option=--interaction=errorstopmode --tex-option=--synctex=-1 "C:\Users\trinker\Desktop\PhD Program\Indep. Study\lit_review_articles_explicit_talk\paper\theories.tex"
Startup Folder: C:\Users\trinker\Desktop\PhD Program\Indep. Study\lit_review_articles_explicit_talk\paper

This is pdfTeX, Version 3.1415926-2.3-1.40.12 (MiKTeX 2.9)
entering extended mode

("C:/Users/trinker/Desktop/PhD Program/Indep. Study/lit_review_articles_explici
LaTeX2e <2011/06/27>
Babel <v3.8m> and hyphenation patterns for english, afrikaans, ancientgreek, ar
abic, armenian, assamese, basque, bengali, bokmal, bulgarian, catalan, coptic, 
croatian, czech, danish, dutch, esperanto, estonian, farsi, finnish, french, ga
lician, german, german-x-2012-05-30, greek, gujarati, hindi, hungarian, iceland
ic, indonesian, interlingua, irish, italian, kannada, kurmanji, latin, latvian,
 lithuanian, malayalam, marathi, mongolian, mongolianlmc, monogreek, ngerman, n
german-x-2012-05-30, nynorsk, oriya, panjabi, pinyin, polish, portuguese, roman
ian, russian, sanskrit, serbian, slovak, slovenian, spanish, swedish, swissgerm
an, tamil, telugu, turkish, turkmen, ukenglish, ukrainian, uppersorbian, usengl
ishmax, welsh, loaded.
Document Class: apa6e 2011/03/03 v0.3 APA 6e manuscript formatting
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\article.cls"
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\size12.clo"))
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\psnfss\times.sty")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\psnfss\mathptmx.sty")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\geometry\geometry.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\graphics\keyval.sty")
("C:\Program Files (x86)\MiKTeX 2.9\tex\generic\oberdiek\ifpdf.sty")
("C:\Program Files (x86)\MiKTeX 2.9\tex\generic\oberdiek\ifvtex.sty")
("C:\Program Files (x86)\MiKTeX 2.9\tex\generic\ifxetex\ifxetex.sty")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\geometry\geometry.cfg"))
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\float\float.sty")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\ifthen.sty"))
("C:\Program Files (x86)\MiKTeX 2.9\tex\generic\babel\babel.sty"
* Local config file bblopts.cfg used
("C:\Program Files (x86)\MiKTeX 2.9\tex\generic\babel\english.ldf"
("C:\Program Files (x86)\MiKTeX 2.9\tex\generic\babel\babel.def")))
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\misc\etex.sty"))
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\oberdiek\kvoptions.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\generic\oberdiek\ltxcmds.sty")
("C:\Program Files (x86)\MiKTeX 2.9\tex\generic\oberdiek\kvsetkeys.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\generic\oberdiek\infwarerr.sty")
("C:\Program Files (x86)\MiKTeX 2.9\tex\generic\oberdiek\etexcmds.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\generic\oberdiek\ifluatex.sty"))))
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\ltxmisc\url.sty")

Package biblatex Warning: Macro 'reviewauthor' undefined.
(biblatex)                Using \newbibmacro.

) (C:\Users\trinker\AppData\Roaming\MiKTeX\2.9\tex\latex\biblatex-apa\apa.cbx)
 ("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\tools\enumerate.sty")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\hyperref\hyperref.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\generic\oberdiek\hobsub-hyperref.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\generic\oberdiek\hobsub-generic.sty"))
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\hyperref\pd1enc.def")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\00miktex\hyperref.cfg"))

Package hyperref Message: Driver (autodetected): hpdftex.

("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\hyperref\hpdftex.def"
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\oberdiek\rerunfilecheck.sty"))
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\graphics\graphicx.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\graphics\graphics.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\graphics\trig.sty")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\00miktex\graphics.cfg")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\pdftex-def\pdftex.def")))
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\textcomp.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\ts1enc.def"))
) (C:\Users\trinker\AppData\Roaming\MiKTeX\2.9\tex\latex\placeins\placeins.sty)
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\ams\math\amsmath.sty"
For additional information on amsmath, use the `?' option.
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\ams\math\amstext.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\ams\math\amsgen.sty"))
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\ams\math\amsbsy.sty")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\ams\math\amsopn.sty"))
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\graphics\color.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\00miktex\color.cfg"))
("C:\Users\trinker\Desktop\PhD Program\Indep. Study\lit_review_articles_explici
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\ts1cmr.fd")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\psnfss\ot1ptm.fd")
*geometry* driver: auto-detecting
*geometry* detected driver: pdftex
ABD: EverySelectfont initializing macros

Package biblatex Warning: File 'theories.bbl' is wrong format version - expecte
d 2.1.

("C:\Users\trinker\Desktop\PhD Program\Indep. Study\lit_review_articles_explici
! Undefined control sequence.
<argument> ...c@refsection @entry@\blx@slist@name 

l.119 \endentry

! Undefined control sequence.
<argument> ...c@refsection @entry@\blx@slist@name 

l.119 \endentry

! Undefined control sequence.
l.121 \lossort

! Undefined control sequence.
l.122 \endlossort

) ("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\hyperref\nameref.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\generic\oberdiek\gettitlestring.sty"))
("C:\Users\trinker\Desktop\PhD Program\Indep. Study\lit_review_articles_explici
("C:\Users\trinker\Desktop\PhD Program\Indep. Study\lit_review_articles_explici
[Loading MPS to PDF converter (version 2006.09.02).]
) (C:\Users\trinker\AppData\Roaming\MiKTeX\2.9\tex\latex\microtype\mt-ptm.cfg)
Underfull \hbox (badness 2941) in paragraph at lines 83--83
 []\OT1/ptm/m/n/12 (+20) Teacher Metacog-ni-tion: The In-ten-tion-al-ity of Tea
cher Led Speech 

Underfull \hbox (badness 10000) in paragraph at lines 83--83
 []\OT1/ptm/m/n/12 (+20) Tyler Rinker 

Underfull \hbox (badness 10000) in paragraph at lines 83--83
 []\OT1/ptm/m/n/12 (+20) University at Buf-falo 

Underfull \hbox (badness 10000) in paragraph at lines 83--83
 []\OT1/ptm/m/n/12 (+20) Department of Learn-ing and In-struc-tion 
Underfull \hbox (badness 2922) in paragraph at lines 83--83
 [][]\OT1/ptm/m/n/12 (+20) Teacher Metacog-ni-tion: The In-ten-tion-al-ity of T
eacher Led Speech 

Underfull \hbox (badness 10000) in paragraph at lines 109--109
 [][]\OT1/ptm/b/n/12 Literature Re-view 

Underfull \hbox (badness 10000) in paragraph at lines 118--118
 [][]\OT1/ptm/b/n/12 Methods 

Underfull \hbox (badness 10000) in paragraph at lines 124--124
 [][]\OT1/ptm/b/n/12 Results 

Underfull \hbox (badness 10000) in paragraph at lines 126--126
 [][]\OT1/ptm/b/n/12 Conclusion 

LaTeX Warning: Empty bibliography on input line 134.

("C:\Users\trinker\Desktop\PhD Program\Indep. Study\lit_review_articles_explici

Package biblatex Warning: Please rerun LaTeX.
(biblatex)                Page breaks have changed.

(\end occurred when \ifx on line 46 was incomplete)
(\end occurred when \ifx on line 46 was incomplete)
(\end occurred when \ifx on line 46 was incomplete)pdfTeX warning (dest): name{
cite.0@Nagy1985} has been referenced but does not exist, replaced by a fixed on

{C:/Program Files (x86)/MiKTeX 2.9/fonts/enc/dvips/fontname/8r.enc}<C:/Program 
Files (x86)/MiKTeX 2.9/fonts/type1/urw/times/utmb8a.pfb><C:/Program Files (x86)
/MiKTeX 2.9/fonts/type1/urw/times/utmr8a.pfb>
Output written on theories.pdf (2 pages, 35260 bytes).
SyncTeX written on theories.synctex.
Transcript written on theories.log.
texify: pdflatex.exe failed for some reason (see log file).


 PDFTeXify Compilation Report (Pages: 2)

 Errors: 4   Warnings: 5   Bad Boxes: 9

It still makes a pdf but with no references.

I'm not really that great with LATEX (love it's flexibility but am not really knowledgeable). So please make sure your answers assume nothing.

EDIT: I changed the code and the output above to reflect the problem after trying the solutions given

  • using miktex 2.9 on win7 machine with jabref 2.7 Commented Aug 16, 2012 at 1:49
  • A broken biblatex was uploaded to CTAN awhile back. You should run MikTeX's update manager to resolve the problem.
    – Audrey
    Commented Aug 16, 2012 at 2:03
  • @Audrey I ran the update manager and the problem persists Commented Aug 16, 2012 at 2:13
  • 2
    You have missed out the file extension in \atbibresource: unlike \bibliography this does not assume .bib. If I correct this, all is well.
    – Joseph Wright
    Commented Aug 16, 2012 at 6:47
  • I've tried the suggestion to add the .bib file extension as well as use the bibencoding=latin1 argument and the problem persists. Please let me know if there's any files or output from MikTex that would provide more information and I'll supply them. Commented Aug 16, 2012 at 13:27

1 Answer 1


There are two issues with your files. Firstly, \addbibresource requires the full file name including the extension .bib. Secondly, your bibliography file includes foreign characters in latin1 encoding (e.g. in the French abstract). This means (a) that you need to use a bibliography program that understands such encondings, biber is a good choice, and (b) you need to tell biber about this encoding. This you can do with the option bibencoding=latin1.

Thus, all you really need to do is change two lines in your main file to


Before trying to compile this, clean out all the generated files from the directory so that you just have your .tex and .bib file left, otherwise you will get all sorts of potentially confusing error messages.

  • I added exactly what you said and deleted everything except the tex file and the bib file and the same problem happens. I included the new error message above (updated the old one) in hopes this provides now information. It's saying something about expecting a different format. Also the information of that if I change it to bibtex as the back end, run it and then change back to biber as the back end is the only way to get the green hyper reference box and the years print, other wise it prints the bold BibTex keys. Commented Aug 16, 2012 at 13:20
  • The log file comes from a run with bibtex, the main file expects a biber generated .bbl file. Just use biber, starting from scratch including deleting the .bbl file before compiling. Switching backwards and forwards between biber and bibtex causes confusion. On my system I get the coloured hyperlinks you seem to be missing. Commented Aug 16, 2012 at 13:38
  • I only tell this information because I discovered it on an accident and I think it may hold information to solve the problem. I believe this problem may be specific to this computer because the same file can be run on another computer. What am I missing? What could be different with this computer? Could it be something with jabref? Is jab ref needed to compile a tex file into a pdf? Could it be something with my path set up? A missing .sty file? Commented Aug 16, 2012 at 13:49
  • This at least gets the hyper refs printing in text. It seems to now be a problem with my set up with biber. I'm marking this thread as solved and starting a new question. Commented Aug 16, 2012 at 22:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .