I am trying to submit a revised article to Elsevier Journal of Computer Network through https://editorialmanager.com I am submiting my .tex files that were written on OverLeaf.com. the way this works, is that the Editorial Manager is supposed to generate a pdf file from my .tex files. But the final .pdf file that I am getting only prints a along log that starts with:

This is pdfTeX, Version 3.141592653-2.6-1.40.24 (TeX Live 2022)
(preloaded format=pdflatex 2022.12.28) 7 FEB 2023 12:24
entering extended mode
restricted \write18 enabled.
%&-line parsing enabled.
LaTeX2e <2022-11-01> patch level 1
L3 programming layer <2022-12-17> (c:/TeXLive/2022/texmfdist/tex/latex/elsarti
Document Class: elsarticle 2020/11/20, 3.3: Elsevier Ltd
Package: expl3 2023-01-24 L3 programming layer (loader)
! LaTeX Error: Mismatched LaTeX support files detected.
(LaTeX) Loading 'expl3.sty' aborted!
(LaTeX) The L3 programming layer in the LaTeX format
(LaTeX) is dated 2022-12-17, but in your TeX tree the files
(LaTeX) at least 2023-01-24.

I had this problem with the original submission but I managed to solve it by changing my compiler on OverLeaf.com from pdfLatex to Latex and fixing the formating issues. However, this time I can't go around this error, even though I tried submiting the same files that I used for the first submission of my article.

Could you please offfer some help on this. Thank you for your time and patience.

  • 1
    If this log is generated on the Elsevier site by them, then it's a problem only they can solve. If you are uploading packages as well as your source document then it's a problem that you might be able to solve by using an older TeX Live version. But that doesn't seem to be what's going on.
    – Alan Munn
    Feb 7, 2023 at 18:23
  • 4
    I have the exact same problem. I contacted Elsevier's support yesterday and they said it's their problem and they're gonna fix it asap. Still doesn't work though...
    – Gerger
    Feb 7, 2023 at 20:59

3 Answers 3


I recently had the same issue and contacted Elsevier Support. They gave me the following links:

As seen in the first link, you have to upload the pdf as the manuscript file, then bundle everything else used to compile your source files in a zip file and include them as "LaTeX source files" item in your submission. Note that this is exactly the opposite of the instructions given in Editorial Manager when uploading your files, which state that during the revision process, you need to upload your source files and not the pdf for the manuscript.


So to answer my own question, I have contacted the Elsevier Support Team and explained the problem to them. So they asked me to compile the .pdf on my computer and send it to them, I did as they asked (I sent them two files one with the changes highlighted and the other is the final manuscript). They uploaded both .pdf files for me, and then I was able to go on with the submission.


I experienced the same problem when submitting my article.

Try following procedures which might be helpful.

  • Mark all latex source files as manuscript
  • Remove the latex style file when submitting, e.g., elsarticle.cls
  • Worked with me.
    – Ahmed
    Apr 2, 2023 at 21:37
  • Thanks! I also needed to remove the bibliography style file (elsarticle-harv.bst)
    – PeterD
    Apr 26, 2023 at 8:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .