0

I'm using the glossaries package with acronym option to list the abbreviations used in my dissertation. Unfortunately, I am facing problems using \glsfirst{} to display the long text that is intended to show up on initial use of \gls{}. When generating the following example locally on my computer with MikTeX (updated to latest version 22.10 x64), then \glsfirst{ecg} does not show the long text. If I run the example on overleaf.com instead, it works smoothly. However, I cannot/don't want to generate the huge document on overleaf ...

Do you have any idea how to solve this problem? Thank you!

\documentclass{scrbook}
\usepackage[english]{babel}

\usepackage[automake, acronym, nopostdot]{glossaries}
\makeglossaries

\newacronym{ecg}{ECG}{electrocardiography}

\begin{document}

First use of \gls{ecg} and then the second use \gls{ecg}.

The first, long version again \glsfirst{ecg}.

\end{document}

1 Answer 1

0

Had a similar problem that could be solved by loading the package glossaries-extra instead of glossaries. In addition, the abbreviation style has to be defined, e.g. to gain the form "electrocardiography (ECG)" by:

\setabbreviationstyle[acronym]{long-short}

This is because the default option of glossaries-extra is short-nolong, which omits the long version of the acronym.

As an alternative, reset the first use flag manually prior to \gls{ecg} with \glsreset{ecg}\gls{ecg} or short \gls[prereset]{ecg}. Details can be found in the manual of the glossaries-extra package.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .