1

While running the package-supplied *.tex samples for pagelayout.cls, I am getting error messages. That alone is odd, because I would expect those examples to be rock-solid. The errors claim that the compiler didn't have shell access, and so it aborted the run.

I have tried the same files in TexWorks and in Kile....same errors reported. And neither of them suggest a way of resolving the problem.

Any ideas about why this error is occurring?

PS--would someone with a reputation >300 please add the "pagelayout" tag (tag zfpagelayout exists, but it is not the same package)

*******************Update, reply to Friedmann ************ ImageMagick version is 6.9.11.60. I cannot find a way to upgrade to 7 or higher. there are no higher versions in the Linux_Mint synaptic repository. I tried updating via sudo apt update but that failed.

I ran xelatex example-borders-and-shadows.tex as you suggested and I got this error message at the end of several dozen lines:

/usr/local/texlive/2022/texmf-dist/tex/latex/l3backend/l3backend-xetex.def
runpopen command not allowed: extractbb

! I can't find file `"|extractbb --version"'.
<to be read again> 
                   \scan_stop: 
l.72     \l__sys_internal_tl
                            
(Press Enter to retry, or Control-D to exit)
Please type another input file name: 
7
  • The package pagelayouts needs shell-escape to run as can be seen in /scripts/pagelayoutapi and the errors present in pagelayout.cls (if you CTRL+F and type "shell" you can see the error messages/commands). The way around it is to enable shell-escape, if you have a full installation of TeXlive (where TeXworks comes from) then you can use arara to do shell-escape like % arara: pdflatex: {shell: yes, options: [-halt-on-error]}, you need to setup the path to arara in TeXworks like this: tex.stackexchange.com/a/98795/273733
    – JamesT
    Feb 24, 2023 at 7:02
  • I am not sure how to do it in native LaTeX or with latexmk as I use arara exclusively, hopefully someone else can help with that (note: the -halt-on-error option is so that if errors cause the programme to end without compiling it doesn't leave pdflatex.exe hanging and not being able to delete aux files, if that happens you need to kill the process manually)
    – JamesT
    Feb 24, 2023 at 7:03
  • I wouldn't run examples with --shell-escape without first inspecting them carefully. --shell-escape gives them access to your computer. Feb 24, 2023 at 8:31
  • Ulrike: Are you suggesting that the examples included by the creator of pagelayout.cls (Mssr. F. Bartels) would actually have malicous content? Is the shell script actually capable of behaving maliciously?
    – Birdman
    Feb 24, 2023 at 19:57
  • I set up arara, and got further (that is, fewer error messages). But I still got an error message execcv forbidden
    – Birdman
    Feb 25, 2023 at 6:41

1 Answer 1

0

Troubleshooting shell access with pagelayout class:

  1. Make sure Inkscape version 1.0 or higher is installed by running inkscape --version.

  2. Make sure ImageMagick version 7.0 or higher is installed by running magick --version.

  3. Make sure the pagelayoutapi script is installed by running pagelayoutapi --version.

  4. Try to build the example example-borders-and-shadows.tex by running xelatex example-borders-and-shadows.tex. If an error occurs type H for help and follow the instructions.

If you still run into errors, please let me know:

  • the exact error
  • your TeX distribution
  • how you installed the package

Note: after updating the texmf.cnf you do not need to run sudo texhash. This command is only required when manually installing the package.

10
  • Inkscape is OK. Pagelayoutapi is OK. ImageMagick version is 6.9.11.60 (see edits in the original question). Xelatex run fails (see edits in the original question). Thanks, Friedemann, for your response...very much appreciated.
    – Birdman
    Mar 1, 2023 at 5:20
  • Oh, I had installed the pagelayout.cls package using the tlmgr --gui. That was on 24th Feb, after nuke-and-pave and reinstall of TexLive 2022. Today, tlmgr does NOT work anymore. See my latest question on this forum, added today.
    – Birdman
    Mar 1, 2023 at 5:22
  • Is there a particular Path setting that pagelayout.cls (or, indeed, LaTeX) uses to locate Imagemagick, Inkscape when those supporting programs are called?
    – Birdman
    Mar 2, 2023 at 22:02
  • It seems like I have resolved problems with shell access now.
    – Birdman
    Mar 5, 2023 at 17:58
  • But, issues with "inkscape not found" and "imagemagick not found" are still present even though they are in my $PATH. I checked $PATH from the directory of TeXLive 2022 and they are both there. These error messages are definitely generated by the code 'pagelayout.cls' (for examples, at lines 3660, 3661), but I've been unable to discover where 'pagelayout.cls' expects to find these accessory programs. And with particular reference to Imagemagick, which of the individual routines of I.M. does it require?
    – Birdman
    Mar 5, 2023 at 18:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .