2

Please look at my MWE. I would expect odd and even side margins being the same but they are not. What I am doing that is wrong? (I added most of my preamble just in case it matters...).

\documentclass[foolscap, 12pt]{octavo}
\usepackage{xcolor}
\usepackage{anyfontsize}
\usepackage{fancyhdr}
\usepackage[
paperwidth=115mm, paperheight=195mm,
layoutsize={110mm, 190mm},
textheight=15.5cm,
textwidth=8.5cm,
outer=1.5cm,
inner=1cm,
top=1.5cm,
bottom=2cm
    ]
    {geometry}
\usepackage[italian]{varioref}
\usepackage[italian]{babel}
\usepackage[babel=true]{microtype}%%% 
\usepackage{blindtext}
\usepackage{layout}
%MULTIPLE COLUMNS
\usepackage{paracol}
\twosided
\footnotelayout{m}
\columnsep=0.1\textwidth
\columnratio{0.65}

\usepackage{fontspec}
\usepackage{polyglossia}
\usepackage{ebgaramond}
\setdefaultlanguage{italian}

\usepackage{showframe}
\begin{document}
\sloppy
%%%%%%%%%%%%%%%%%%%%%%%%%STARTHERE%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\layout

\chapter{1}
\blindtext[3]

\end{document}
14
  • 4
    You define two margins of unequal length. The outer margin is the right one and the inner one is the left side. If you want equal margins, you need to keep those the same (or insert a bindingoffset of 5 mm which will equal both sides too) See the manual of geometry about the definitions of inner and outer.
    – alchemist
    Commented Mar 7, 2023 at 20:17
  • 3
    Have you checked whether the paperwidth=115mm, paperheight=195mm, and layoutsize={110mm, 190mm} are mutually compatible? For sure, if I comment out layoutsize={110mm, 190mm}, I instantly get better results.
    – Mico
    Commented Mar 7, 2023 at 20:52
  • 1
    Yes MICO your suggestion works!
    – Haim
    Commented Mar 7, 2023 at 21:12
  • 1
    If you post it as an answer I will accept it. Thanks so much!
    – Haim
    Commented Mar 7, 2023 at 21:44
  • 1
    @Mico would you like to post an answer? I'm editing the question now to add the octavo tag that I created so it will be bumped to the top now anyhow :)
    – JamesT
    Commented Apr 19, 2023 at 11:19

1 Answer 1

2

I strongly recommend you comment out the option

layoutsize={110mm, 190mm}

while loading the geometry package. It doesn't seem to do anything useful anyway, at least not in the test document at hand.

A separate comment: Don't load both babel and polyglossia. Use one or the other, but not both simultaneously.

enter image description here

\documentclass[foolscap, 12pt, italian]{octavo}
\usepackage{xcolor}
\usepackage{anyfontsize}
\usepackage{fancyhdr}
\usepackage[
    paperwidth=115mm, paperheight=195mm,
    %%%layoutsize={110mm, 190mm}, % <-- comment out this line
    textwidth=85mm, textheight=155mm, 
    outer=1.5cm, inner=1cm, 
    top=1.5cm,   bottom=2cm,
    showframe
    ]
    {geometry}
\usepackage{varioref,babel,microtype}
\usepackage{blindtext}

%MULTIPLE COLUMNS
\usepackage{paracol} % do you need this?
\twosided
\footnotelayout{m}
\columnsep=0.1\textwidth
\columnratio{0.65}

\usepackage{fontspec}
\usepackage{ebgaramond}

%%\usepackage{polyglossia} % don't load both 'babel' and 'polyglossia'
%%\setdefaultlanguage{italian}

\begin{document}
%% \sloppy % <-- why?

%\layout

\chapter{AA}
\blindtext[6]

\end{document}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .