0

My zotero+BetterBibTeX has exported some citations like this

@article{abduMagneticDeclinationControl1981,
  title = {Magnetic Declination Control of the Equatorial {{F}} Region Dynamo Electric Field Development and Spread {{F}}},
  author = {family=Abdu, given=MA, given-i=MA and family=Bittencourt, given=JA, given-i=JA and family=Batista, given=IS, given-i=IS},
  date = {1981},
  journaltitle = {Journal of Geophysical Research: Space Physics},
  shortjournal = {Journal of Geophysical Research: Space Physics},
  volume = {86},
  number = {A13},
  pages = {11443--11446},
  publisher = {{Wiley Online Library}},
  issn = {0148-0227},
  keywords = {F-region scintillation's cause}
}

I've never seen the options "family=" or "given=" before. Even though, I tried to use it that way, and when I cited it, my LaTeX didn't not properly handle these fields. It results in enter image description here

How to handle (or remove) it in order to get a sane citation?

1
  • 2
    that is syntax for biblatex so probably you have set somewhere an option that you use biblatex. Mar 10, 2023 at 8:24

1 Answer 1

2

Actually I found the solution. In (using Zotero 6.0.22):

  1. Edit
  2. Preferences
  3. Better BibTeX
  4. Export
  5. BibLaTeX -> Export -> BibLaTeX
  6. Uncheck "Use BibLaTeX extended name name format (requires biblatex 3.5)"

enter image description here

It disables these weird fields in the citation options.

2
  • Which is exactly what Ulrike Fischer told you in a comment.
    – cfr
    Nov 12, 2023 at 4:17
  • @cfr No. He told a guess. I told the answer. Nov 13, 2023 at 6:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .