1

I am trying to use \citeautor to cite author names automatically in Chinese text as follows:

\citeauthor{key}提出了一种方法 \cite{key}。

which will result in:

A et al. 提出了一种方法[1]。

What I want is:

A等提出了一种方法[1]。

by:

  1. remove the space before et al.
  2. change et al. to

Update: I just tried to provide an MWE,but could not solve it. I am using this template from GitHub: https://github.com/1FCENdoge/SYSUThesis

6
  • 2
    Without any code that others can copy and test as is, it is vry hard to know what exactly you are doing and thus provide any help. Note that in general for bibtex keywords like et al. is baked into the bibtex style and is not really configurable in most cases. Have you considered using biblatex instead?
    – daleif
    Mar 16, 2023 at 13:33
  • 3
    You haven't given us nearly enough information to answer your question. What \bibliographystyle are you using? But independent of that, natbib + bibtex isn't really set up to deal with Unicode .bib files, so you really should consider switching to biblatex + biber.
    – Alan Munn
    Mar 16, 2023 at 13:33
  • @daleif Sorry for that. I just tried to add some example, but could not resolve it. I am using a template in github.com/1FCENdoge/SYSUThesis .The template is based on a .bst file. So I think only bibtex is available.
    – yangtzech
    Mar 16, 2023 at 15:36
  • @AlanMunn The style is gbt7714-bibtex-style from github.com/zepinglee/gbt7714-bibtex-style. The template I am using is based on the .bst file. I'll see if I am able to change the template to use biblatex if it's the only option.
    – yangtzech
    Mar 16, 2023 at 15:39
  • I'm very skeptical that this will work very well, but you can try adding \renewcommand{\bibetal}{等} and \renewcommand{\biband}{和} to your preamble. This class makes the mistake of trying to do too much for you, unfortunately, and it has quite a bit of natbib specific code, so it might be non-trivial to modify it to allow biblatex, although I'm sure that would be a better solution.
    – Alan Munn
    Mar 16, 2023 at 16:39

0

You must log in to answer this question.

Browse other questions tagged .