I'm new to LaTeX, and have been given a LaTeX draft for writing a thesis. Everything works fine except for this warning:

see the transcript file for additional information)pdfTeX warning (dest): name{ehrenw\366rtliche\040erkl\344rung.1} has been referenced but does not exist, replaced by a fixed one

Here is the position in the code:

\pdfbookmark[1]{Ehrenwörtliche Erklärung}{ehrenwörtliche erklärung}  
\chapter*{Ehrenwörtliche Erklärung}  

When I don't use German Umlauts(ä,ö,ü), i.e.

\pdfbookmark[1]{Ehrenwoertliche Erklaerung}{ehrenwoertliche erklaerung}

it works fine! I don't get any warnings and the link works.

I've been Googling for 2 weeks for similar warnings, and trying things out but none worked. Any one with similar experience or ideas how to get this fixed.

I'm using MAC 10.8 with MacTeX-2012

  • The order in which you load the packages can matter, especially with hyperref. If you are using that, try loading it last. tex.stackexchange.com/questions/1863/…
    – yasmar
    Oct 22, 2012 at 15:17
  • I had the same problem. The solution might not apply to you as well, but have a look if there is a \let\clearpage\relax in front of you \printbibliography command.
    – math
    Feb 12, 2014 at 9:30

5 Answers 5


I've had a similar problem, but I've "solved" it.

Online some people seemed to suggest this is to do with hyperref, but, I'm not convinced. Loading hyperref last had no effect whatsoever.

In the .tex file I had:

\begin{proposition}\label{prop:amG delta in amG delta K}

This formats so that the 1. of the \item is right next to the "Proposition 3.6" header.

My log file told me:

pdfTeX warning (dest): name{theorem.3.6} has been referenced but does not exist
, replaced by a fixed one

Then, I inserted some space like this:

\begin{proposition}\label{prop:amG delta in amG delta K}

Now of course the 1. of the \item is below, not next to, the "Proposition 3.6" header, but also, miraculously, the referencing problem is solved!

Don't ask me why, though.

  • 2
    This also worked for me. I had three occurrences of the same error, and they all pertained to lemmas/ propositions with enumeration. Adding some hspace removed the error.
    – Nick Gill
    Jul 9, 2015 at 9:52
  • 3
    Strange. Would be nice to know if one can really fix this, i.e., with keeping the layout as it was before. But thanks for the answer, it "fixed" my problem :)
    – PhoemueX
    Apr 10, 2017 at 16:01

Load the bookmark package:

enter image description here

\usepackage[utf8]{inputenc}% http://ctan.org/pkg/inputenc
\usepackage{hyperref}% http://ctan.org/pkg/hyperref
\usepackage{bookmark}% http://ctan.org/pkg/bookmark
\pdfbookmark[1]{Ehrenwörtliche Erklärung}{ehrenwörtliche erklärung}
\chapter*{Ehrenwörtliche Erklärung} 
  • 1
    Hi Werner, Thanks 4 ur answer. Unfortunately it didn't work, i also installed, updated the oberdiek package sudo tlmgr update oberdiek and sudo -i tlmgr update --all, still the link didn't work. when clicking on the chapter it jumps back to the first page. With ur example i get the same warning. My Tex Version: TeX 3.1415926 (TeX Live 2012) kpathsea version 6.1.0 Copyright 2012 D.E. Knuth.
    – Fadi Asbih
    Aug 21, 2012 at 9:02

I've had a similar problem too, which appears to be related to Poeh's one. I referenced an environment without content


which produced the following error message

pdfTeX warning (dest): name{env.#} has been referenced but does not exist, replaced by a fixed one

(# denotes the reference number). Apparently, pdfTeX correctly processes an environment only if it has some effective content (besides its name, here: foo). In Poeh's case the content is indeed \hspace{2em} since pdfTeX restarts processing environment contents for each subenvironment (that's why \begin{enumerate} is not sufficient to trigger pdfTeX correct response).

If you didn't change anything else besides the Umlauts, then I suspect the warning message might be caused by a wrongful interaction between pdfTeX and hyperref as suggested above. As you can see in the warning, Umlauts are not correctly interpreted (nor, for sure, they are by hyperref, which also does not interpret math symbols, occasionally prompting warnings such as Package hyperref Warning: Token not allowed in a PDF string (Unicode):(hyperref) removing '\mathgroup' on input line 58.).

This issue is much more difficult to deal with, but, since you are under Mac OS, I'd suggest to change your encoding settings to applemac (rather than UTF8, Unicode or anything else).

  • 1
    This helped me solve the problem. Apparently, in the case with the enumerate from Poeh, you can just move the label to the bottom of the environment, then the warning disappears.
    – Markus
    Jan 7, 2015 at 13:06
  • Also helped me. Just had add content (I added '~') to the environment which only had an enumerate.
    – ckamath
    Mar 6, 2020 at 21:24

The quite expensive support of umlauts and other stuff is done for bookmark titles only. Anchor names do not support as many features. Usually they are just simple names and should not contain non-ASCII stuff.

Depending on the input and font encodings, the code can even break, e.g. by using utf8 with OT1.

The anchor names are used as internal unique names in the PDF file. The anchor names are only seen by the outside, if referenced. Then umlauts would cause much additional trouble: Unknown encoding, quoting requirements, ...

Therefore your workaround is the best solution here, replacing umlauts by ASCII letters (äae, ...). Also something shorter could be used here:

\pdfbookmark[1]{Ehrenwörtliche Erklärung}{Erklaerung}

Since \pdfbookmark already creates an anchor, it is not necessary to add \phantomsection or \refstepcounter{dummy}. It is more important that the anchor setting is done at the correct place and especially page:

\pdfbookmark[1]{Ehrenwörtliche Erklärung}{Erklaerung}
\chapter*{Ehrenwörtliche Erklärung}

I got the same problem/warning on my document, and it was caused because I was trying to fix this other warning: How to fix destination with the same identifier (name{page.A}) has been already used, duplicate ignored?

I had added \hypersetup{pageanchor=false} around my whole thesis before text. And this was disabling all anchors inside those pages and any one trying to link with something there was throwing the error: pdfTeX warning (dest): name{page.11} has been referenced but does not exist, replaced by a fixed one

The fix was to add \hypersetup{pageanchor=false} only around the pages which ware actually throwing the warning destination with the same identifier (name{page.1}) has been already used, duplicate ignored


  1. ClassicThesis and acronym warnings: "has been referenced but does not exist, replaced by a fixed one"
  2. "Reference does not exist" warning with \includeonly
  3. Warning with footnotes: "name{Hfootnote.xx} has been referenced but does not exist"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .