I've found a template that works fine in Overleaf (using XeLaTeX), and I decided to download all the files and use it in VS code. The issue is that when I tried to compile the file using Recipe:latexmk (exlatex) but it doesn't work at all! I've tried to figure out why but no luck.

The Overleaf template: https://www.overleaf.com/read/cbqwwttzmfkk

Edit: Adding more information to provide support

I've already installed MikTeX, and the log file is as shown in the link below: https://github.com/TechnocracyArabic/starmap/blob/main/Log%20File

with error as the image below shows: enter image description here

I'm using Windows 10, with LaTeX Workshop v9.7.0, with all packages updated to the latest version.

Thank You for your help.

  • Welcome to TeX.SX! Your question lacks some details, for example: did you install locally a TeX distribution like TeXLive or MikTeX? Mar 19 at 6:47
  • Sorry, I'm new to this forum and I don't know what details to add. But yes, I did install MikTeX
    – AboodJtx
    Mar 19 at 6:59
  • show what code you ran and what error (from the log file) you got. no one can debug "it doesn't work at all!" Mar 19 at 9:18
  • I've updated the question and provided all the information needed (I hope so). Thank you for your patient
    – AboodJtx
    Mar 19 at 11:06
  • it is better to show errors as a text block not an image, and you have still not shown your code, but one error says you have not use \usepackge{bidi} so use that (as you seem to be using polyglossia) your other errors are \swdefault not defined it should be defined by latex (2020/02/02 release) so you presumaby have an old latex installation or (for some reason??) have used latexrelease to rollback latex and remove newer features Mar 19 at 11:31


You must log in to answer this question.

Browse other questions tagged .