1

I'm citing a scientific data set for which the "official" BibTeX entry supplied by the data provider looks like this:

@misc{ds548.0,
address = {Boulder CO},
author = {{Research Data Archive, Computational and Information Systems Laboratory, National Center for Atmospheric Research, University Corporation for Atmospheric Research} 
and 
{Physical Sciences Division, Earth System Research Laboratory, OAR, NOAA, U.S. Department of Commerce} 
and 
{Cooperative Institute for Research in Environmental Sciences, University of Colorado} 
and 
{National Oceanography Centre, University of Southampton} 
and 
{Met Office, Ministry of Defence, United Kingdom} 
and 
{Deutscher Wetterdienst (German Meteorological Service), Germany} 
and 
{Department of Atmospheric Science, University of Washington} 
and 
{Center for Ocean-Atmospheric Prediction Studies, Florida State University} 
and 
{National Centers for Environmental Information, NESDIS, NOAA, U.S. Department of Commerce}},
date-added = {2020-07-06 18:21:38 -0500},
date-modified = {2020-07-06 18:23:20 -0500},
publisher = {Research Data Archive at the National Center for Atmospheric Research, Computational and Information Systems Laboratory},
title = {{International Comprehensive Ocean-Atmosphere Data Set (ICOADS) Release 3, Individual Observations}},
url = {https://doi.org/10.5065/D6ZS2TR3},
year = {2016},
Bdsk-Url-1 = {https://doi.org/10.5065/D6ZS2TR3}}

The problem lies in the length of the first author: "Research Data Archive, Computational and Information Systems Laboratory, National Center for Atmospheric Research, University Corporation for Atmospheric Research".

Among other things, the LaTeX engine in Overleaf raises the following error: "you've exceeded 250, the entry-string-size, for entry ds548.0". But even apart from that, an author-year citation that uses the first author as shown will look ungainly in print.

My question is whether there's a way to preserve the "author" information in the citation as it appears in the bibliography at the end while shortening the citation as it appears in the body of the text and also circumventing the 250-character limit. Note that AGU publications only permit the \cite and \citeA commands, and they don't permit \nocite, which precludes one possible workaround.

I'm using the journal-supplied document class 'agujournal2019', which in turn appears to use the 'apacite' bibliography style.

2
  • Please tell us which bibliography style you employ.
    – Mico
    Commented Mar 24, 2023 at 14:07
  • 1
    @Mico : I have added that information at the end of my post. Commented Mar 24, 2023 at 14:20

1 Answer 1

2

Since you employ the apacite citation management package -- with the option natbibapa, right? -- and the eponymous bibliography style, I suggest you make use of natbib's citation aliasing capabilities. E.g., run

\defcitealias{ds548.0}{Research Data Archive et~al. (2016)}

in the preamble and

\citetalias{ds548.0}

in the body of the document.

A separate comment: For an entry of type @misc, all bibliography styles I'm aware of know what to do if they encounter a field called howpublished; however, none of them are programmed to handle a field called publisher. I would therefore rename the publisher field to howpublished. I'd also copy the contents of the address field into the howpublished field, and I'd encase the contents of the title field in a pair of curly braces, to prevent the field's contents from being converted to lowercase. (If nothing else, you should encase the ICOADS acronym in curly braces.)

The following screenshot shows the resulting citation call-out and the first three lines of the associated formatted bibliographic entry.

enter image description here

\documentclass{article} % or 'agujournal2019', if available
\begin{filecontents}[overwrite]{mybib.bib}
% from https://rda.ucar.edu/datasets/ds548.0/citation/
@misc{ds548.0,
 author = "{Research Data Archive, Computational and Information Systems Laboratory, National Center for Atmospheric Research, University Corporation for Atmospheric Research} and {Physical Sciences Laboratory, Earth System Research Laboratory, OAR, NOAA, U.S. Department of Commerce} and {Cooperative Institute for Research in Environmental Sciences, University of Colorado} and {National Oceanography Centre, University of Southampton} and {Met Office, Ministry of Defence, United Kingdom} and {Deutscher Wetterdienst (German Meteorological  Service), Germany} and {Department of Atmospheric Science, University of Washington} and {Center for Ocean-Atmospheric Prediction Studies, Florida State University} and {National Centers for Environmental Information, NESDIS, NOAA, U.S. Department of Commerce}",
 title = "{International Comprehensive Ocean-Atmosphere Data Set (ICOADS) Release 3, Individual Observations}",
 howpublished = "Research Data Archive at the National Center for Atmospheric Research, Computational and Information Systems Laboratory, Boulder CO",
 xaddress = {Boulder CO},
 year  = "2016",
 url = "https://doi.org/10.5065/D6ZS2TR3"
}
\end{filecontents}

\usepackage[natbibapa]{apacite}
\defcitealias{ds548.0}{Research Data Archive et~al. (2016)}
\bibliographystyle{apacite}
\usepackage{xurl} % for long and complicated URL strings

\begin{document}
\citetalias{ds548.0}
\bibliography{mybib}
\end{document}
8
  • Sadly, \defcitetalias triggers an undefined control sequence error. Without picking through the journal-provided class file, I don't exactly how apacite is being used (e.g., which options) or whether the AGU opted to disable specific commands that are otherwise available by default. Commented Mar 24, 2023 at 15:02
  • I can try that, but even if it works, I risk overriding the journal style. AGU seems pretty rigid about what is and isn't permitted in LaTeX submissions. Commented Mar 24, 2023 at 15:10
  • Yes, that broke the \citeA{} command that they require us to use for inline citations. Commented Mar 24, 2023 at 15:12
  • @GrantPetty - Does changing \documentclass{agujournal2019} to \documentclass[natbibapa]{agujournal2019} help?
    – Mico
    Commented Mar 24, 2023 at 15:14
  • 1
    @GrantPetty - In that case, I recommend you contact the journal's editorial office and ask them what you should do, since they appear to forbid all normal and, if I may say so myself, entirely legitimate and proper mechanisms.
    – Mico
    Commented Mar 24, 2023 at 19:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .