I'm using biber.exe and biblatex with the following preamble in my tex document

\documentclass[fontsize =10pt, BCOR=0mm, DIV=default]{scrartcl} 
\usepackage{graphicx} % support the \includegraphics command and options 
\usepackage[bibstyle= nature, citestyle=numeric-comp, sorting=none, backend = biber]{biblatex}%this style compresses the numbering 

\usepackage{setspace} %setting interline spacing 
\bibliography{c} %sets the .bib database \begin{document} \section{Results} 

\section{This is a section}
\subsection{This is a subsection} 
\emph{this is emphasized} This is a reference 

Now since a day I have alot of problems with biber.exe. The problems started to occur after an update of many packages using the automatic update method of my MikTex installation. No matter which bib file or tex file i try, biber.exe is no longer working properly. And the errors looks similar as when I was using an old version of biber.exe once (this is what I get when I execute biber.exe on the .bcf file manually)

G:\Hierarchische clustering manuscript>biber.exe TESTC.bcf 
Could not find or check module 'IPC::Run' [THIS MAY BE A PROBLEM!] at IPC/Cmd.pm line 125 Already tried to use 'IO::Select', which was unsuccessful [THIS MAY BE A PROBLEM !] at IPC/Cmd.pm line 154 INFO - Logfile is 'TESTC.blg' INFO - Found 'TESTC.bcf' INFO - Reading TESTC.bcf INFO - Found 1 citekeys in bib section 0 INFO - Processing bib section 0 INFO - Found 'c.bib' INFO - Processing bibtex format file 'c.bib' for section 0 INFO - Decoding LaTeX character macros into UTF-8 c.bib.utf8, line 4, warning: 36 characters of junk seen at toplevel 

        Unicode::Collate: Can't locate Unicode\Collate\allkeys.txt in @INC (@INC contain s: F:\temp\par-homantg\cache-fa06d357fc5a676eeabf7d32fcd743b55bd08598\inc\lib F: \temp\par-homantg\cache-fa06d357fc5a676eeabf7d32fcd743b55bd08598\inc CODE(0x1262 454) CODE(0x1262754)) 
at Biber.pm line 1412 

And this is the output from the latex logfile (truncated)

LaTeX Warning: Citation 'Beaumont2004' on page 1 undefined on input line 104.

[1] ("G:\Hierarchische clustering manuscript\TESTD.aux")

LaTeX Warning: There were undefined references.

Package biblatex Warning: Please (re)run Biber on the file:
(biblatex)                TESTD
(biblatex)                and rerun LaTeX afterwards.

I hope one of the users or developers could get more into detail about this error. Is it related to my machine, is it related to my .bib file (encoded in the wrong way? again see my previous questions regarding biber.exe) or anything else. ?

I'm using the latest version of biber.exe (downloaded manually from sourceforge) and biblatex 1.0

Minimal minimal working example

\title{clustering analysis}
\author{Tim Homan}
\date{oktober 2010} % 
    \usepackage[backend = biber]{biblatex} 
    \bibliography{testlibrary} %sets the .bib database
\subsection{This is a subsection}
This is a reference \cite{Beaumont2004}

Library download

The library which i use for my testing can downloaded here (rar to save encoding):

download here

  • I don't have problems with a current miktex and biber version: 0.5.7 (use biber -v to get the version). But my tests shows that messages from biber can come from various sources (encoding, bib entry, biblatex options ...). So 1. minimize your example. Remove everything that is not needed to reproduce the problem. 2. Complete your example by adding a small bib-file. 3. Put the files in a zip-file (to save encodings) and put it somewhere on the net for testing. Commented Dec 10, 2010 at 10:13
  • Indeed I'm running v0.6. I have tested a bib file containing one entry. I believe it has something to do with encoding of the bib file. I will post my bib file and a minimal minimal example online soon.
    – Timtico
    Commented Dec 10, 2010 at 11:43
  • I've included a minimal working example (althought not working for me), and a link to a rar bib file. Hope someone can test it on his computer to find out if its encoding related. Tried to encode the bib file manually to UTF8 but no luck either.
    – Timtico
    Commented Dec 10, 2010 at 12:22

3 Answers 3


(I'm a biber developer)

If you are using the binary, it should be impossible for biber to not find Unicode::Collate as it's included "in" biber. The "-f" flag uses perl's built in sorting which is locale aware but completely dependent on your OS locale setup (which is often sub-optimal for many OSes). See the biber PDF manual on sourceforge for more details.

Do you have an old pre-binary perl install of biber anywhere? That's what this looks like to me. I'd do a complete scan of your drive for biber installs.

  • I'm using the binary directly from sourceforge. I don't think I've any preinstalled biber, I only started using biber very recently. Starting wit 0.5-7 and now I'm using 0.6.
    – Timtico
    Commented Dec 16, 2010 at 11:15

I downloaded the current biber from here http://sourceforge.net/projects/biblatex-biber/files/biblatex-biber/current/binaries/Windows/biber.zip/download

and tried your bib and example document and it worked fine.

I:\Z-Test\testlibrary>biber -v
biber version: 0.6

I:\Z-Test\testlibrary>biber test-utf8
INFO - Logfile is 'test-utf8.blg'
INFO - Found 'test-utf8.bcf'
INFO - Reading test-utf8.bcf
INFO - Found 1 citekeys in bib section 0
INFO - Processing bib section 0
INFO - Found 'testlibrary.bib'
INFO - Processing bibtex format file 'testlibrary.bib' for section 0
INFO - Decoding LaTeX character macros into UTF-8
INFO - Sorting entries with Unicode::Collate (level => 3, upper_before_lower =
1, locale => English_United States.1252, UCA version: 5.2.0)
INFO - No sort tailoring available for locale 'English_United States.1252'
INFO - Writing 'test-utf8.bbl' with encoding 'UTF-8'
INFO - Output to test-utf8.bbl

I had biber.exe, your example and the bib-file in an empty folder. And for good measure I also tested with an empty PATH variable so that external ressource like perl can't interfere. Where have you installed biber.exe?

  • I'm running version 0.6 too, and got it from the same location. I run biber.exe from the latex root, where I placed it manually. But position doesnt matter much, when I copy the biber.exe to the directory containing my bcf file and run it from there directly it also doesnt work. What bothers me most is that these errors started after I've updated some packages throught the Miktex/update function.. I don't remember what packages were updated in that process. I will now uninstall miktex and reinstall to see if that is any help :(
    – Timtico
    Commented Dec 10, 2010 at 17:15
  • but thanks alot! now I know it has something to do with my installment
    – Timtico
    Commented Dec 10, 2010 at 17:18


Apparently the error occurs when biber tries to use Unicode::Collate for sorting and can't find it/use it

Instead use Perls build in sorting algorithm, based on language locale (or something). Don't know exactly what this all means, but the following setting works.

Biber -f xxx.bcf

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .