1

I downloaded the ISO image of TeXlive 2023 (specifically, texlive2023-20230313.iso). I also checked the SHA512 sum, and it was good. This ISO was too big to unpack onto any DVD_RW that I had on hand, so I used Gnome MultiWriter to "burn" the ISO to the USB. This was accomplished without any error. Using root privileges, I issued the command # perl install-tl -gui. Rather than getting the GUI (despite the fact that I have Tcl/Tk installed), a message flashed by, in the gist of cannot execute wish... but this was not retrievable. I then got the interface, below:

======================> TeX Live installation procedure <=====================

======>   Letters/digits in <angle brackets> indicate   <=======
======>   menu items for actions or customizations      <=======
= help>   https://tug.org/texlive/doc/install-tl.html   <=======

 Detected platform: GNU/Linux on x86_64
 
 <B> set binary platforms: 2 out of 6

 <S> set installation scheme: scheme-full

 <C> set installation collections:
     41 collections out of 41, disk space required: 8065 MB (free: 118421 MB)

 <D> set directories:
   TEXDIR (the main TeX directory):
     !! default location: /usr/local/texlive/2023
     !! is not writable or not allowed, please select a different one!
   TEXMFLOCAL (directory for site-wide local files):
     /usr/local/texlive/texmf-local
   TEXMFSYSVAR (directory for variable and automatically generated data):
     /usr/local/texlive/2023/texmf-var
   TEXMFSYSCONFIG (directory for local config):
     /usr/local/texlive/2023/texmf-config
   TEXMFVAR (personal directory for variable and automatically generated data):
     ~/.texlive2023/texmf-var
   TEXMFCONFIG (personal directory for local config):
     ~/.texlive2023/texmf-config
   TEXMFHOME (directory for user-specific files):
     ~/texmf

 <O> options:
   [X] use letter size instead of A4 by default
   [X] allow execution of restricted list of programs via \write18
   [X] create all format files
   [X] install macro/font doc tree
   [X] install macro/font source tree
   [X] create symlinks to standard directories
   [X] after install, set CTAN as source for package updates

 <V> set up for portable installation

Actions:
 <I> start installation to hard disk
 <P> save installation profile to 'texlive.profile' and exit
 <Q> quit

Enter command: I
Installing to: /usr/local/texlive/2023
username@username-computername:/media/username/TeXLive2023$

I did relent, gave up on having access to the GUI, and simply plugged away with this command-line menu, setting options etc. I then executed the action . I must point out that installation does not, in fact, take place.

I've read the documentation, but I cannot see where the error is.


I carried out all of the installation commands while operating as "root"

/
/
Enter command: I
Installing to: /usr/local/texlive/2023
root@username-computername:/media/username/TeXLive2023#
/
/
/

at this juncture, I waited 15 minutes (as there was some HDD activity). But when I checked, a directory /usr/local/texlive/2023 still had not been created.

I did the same routine with the installer as before, but instead I asked for it to print the installation profile only, then exit <P>. The terminal output made it appear as if something was being 'printed' (to file), but I searched all of my directory tree, and it is NOT there.

7
  • Did you press D to tell the installer which folder to install to? The user you're running the installer as does not have access to the default location.
    – daleif
    Apr 8, 2023 at 10:54
  • Btw i would not recommend adding symlinks unless you really know what you ate doing as they can be a pain to remove afterwards
    – daleif
    Apr 8, 2023 at 10:55
  • Hmmmm. I did try to run as Root, but it seems to me that I had the same problem. Also, I am very curious as to why the GUI isn't appearing on startup.
    – Birdman
    Apr 9, 2023 at 0:00
  • I will also forgo the symlinks, as you suggest.
    – Birdman
    Apr 9, 2023 at 0:01
  • You seem to be on Linux. The GUI is written in perl-tk (afair) and you'll have to install that first. Imo you don't win much by using the gui.
    – daleif
    Apr 9, 2023 at 6:11

1 Answer 1

0

I had previously installed TeXlive 2022 using the DVD method (note that 2022 was small enough to fit on a standard 4.7GB DVD, but 2023 is ~6GB and I had to move to a USB stick). I did not have any problem of this sort when installing 2022 from the DVD, which was created from an ISO image.

I persevered. As noted above, I ran the installer several times as 'root' and as 'user' with the same failure mode (it simply refused to start).

I did go through the installation routine and checked each of the installation directories that were suggested (using the "D" option before running the installer). There was nothing weird there. And during the prior installation of 2022 from DVD, I didn't do anything w.r.t the directories, just accepted the defaults and ran the installer.

I hit upon the idea of manually creating the primary directory for the new installation (being: /usr/local/texlive/2023). I then tried the installation again. And, it ran and installed successfully.

In summary, it seems that the 2023 installer either doesn't have the mkdir function at all, or there is some problem with it creating the primary directory (again, in my case, /usr/local/texlive/2023). Any and all of the other directories required were subsequently created by the TeXlive 2023 installer.

The other issue is, as noted in the original query, that the install-tl gui or install-tl -gui command doesn't work (regardless of whether one attempts to run it as 'root' or as 'user'); it didn't seem to generate an error message, it just gave me the terminal-window display instead.

I will post a note on the TUG site about this, and link back to this question.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .