0

I am now learning LaTeX from the beginning to write my thesis, and doing it on Overleaf. I have a template from my home university, so I use it as a benchmark.

I am now trying to create a reference page and want to cite a source in Korean. The provided preamble(?) looks like this:

\documentclass[
10pt, % The default document font size, options: 10pt, 11pt, 12pt
%oneside, % Two side (alternating margins) for binding by 
default, uncomment to switch to one side
english, % ngerman for German
onehalfspacing, % Single line spacing (singlespacing), 
alternatives: onehalfspacing or doublespacing
% draft, % Uncomment to enable draft mode (no pictures, no links, 
overfull hboxes indicated)
% nolistspacing, % If the document is onehalfspacing or 
doublespacing, uncomment this to set spacing in lists to single
liststotoc, % Uncomment to add the list of figures/tables/etc to 
the table of contents
%toctotoc, % Uncomment to add the main table of contents to the 
table of contents
parskip, % Uncomment to add space between paragraphs
%nohyperref, % Uncomment to not load the hyperref package
headsepline, % Uncomment to get a line under the header
%chapterinoneline, % Uncomment to place the chapter title next to 
the number on one line
% consistentlayout, % Uncomment to change the layout of the 
declaration, abstract and acknowledgements pages to match the 
default layout
]{ThesisXXX} % The class file specifying the document structure
\usepackage[utf8]{inputenc} % Required for inputting 
international characters
\usepackage[T1]{fontenc} % Output font encoding for international 
characters
\usepackage{fontawesome} % Awesome symbol for usage
\usepackage{wrapfig} % Add enbedded figure in the text
\usepackage{tikz} % Add the signature figure overlap the text
% \usepackage[labelformat=simple]{subcaption} % Add multiple 
subfigures in a figure environment
% \captionsetup{justification=justified, margin=0pt}
% \renewcommand\thesubfigure{(\Alph{subfigure})} % change the 
image numbering and reference link to (A),(B),(C), ...... format
\usepackage{pdfpages}
\usepackage{mathpazo} % Use the Palatino font by default
%\usepackage[backend=bibtex,style=authoryear-icomp,natbib=true,] 

{biblatex} % Use the bibtex backend with the authoryear citation style (which resembles APA) %\usepackage[korean,english]{babel} \usepackage[style=apa, backend=biber,natbib=true, autostyle=true]{biblatex}

\addbibresource{thesis.bib} % The filename of the bibliography
\usepackage[autostyle=true]{csquotes} % Required to generate 
language-dependent quotes in the bibliography
\AtBeginEnvironment{enquote}{\itshape} % change the quote words 
to italics style
\usepackage{rotating} % Required to add rotated big tables
\usepackage[normalem]{ulem} % Required to add dashed underlines
\usepackage{indentfirst}
\setlength\parindent{2em}
%%%%%%%
\printbibliography[heading=bibintoc]

And the example citation looks like @article{김낙년2016한국의, title={한국의 부의 불평등, 2000-2013: 상속세 자료에 의한 접근[Wealth Inequality in Korea, 2000-2013: An Approach by Inheritance Tax Data]}, author={Kim, NakNyeon}, journal={경제사학[Review of Economic History]}, volume={40}, number={3}, pages={393--429}, year={2016} }

However, the printed reference only gives my translation in English with the original title omitted.

These are things that I tried after consulting StackExchange.

  1. %\usepackage[korean,english]{babel} add this line in the preamble I tried it, but it yields an error message saying that "option clash for package babel" with a red mark on %\usepackage[style=apa, backend=biber,natbib=true, autostyle=true]{biblatex} this line. Even if I change autostyle to babel, it gives the same result.

  2. include language and hyphenation in each citation that is in Korean. It did not work.

  3. I am not trying to touch any of BibLaTeX since currently I have the ideal format for reference.

  4. After reading https://www.overleaf.com/learn/latex/Korean#Example_using_Google_Noto_CJK_fonts and How do I get Korean (Hangul) characters to typeset in LaTeX ?, I tried both \usepackage{xeCJK}
    \setCJKmainfont{SimSun}
    \setCJKsansfont{SimHei}
    \setCJKmonofont{FangSong}
    \setCJKmainfont{Gulim}
    and \usepackage{kotex} but, the first one does not change anything, and the second one gives an error

This is how my current reference looks

1
  • 1
    My guess is that your problem is not at all related with biblatex or babel but with the lack of korean capable font to print even a simple 안녕하세요 세계 (hello World) test. Check for example if \documentclass{article}\usepackage{fontspec}\setmainfont[Mapping=tex-text]{Noto Sans CJK KR} \begin{document} Hello World 안녕하세요 세계 \end{document}, works with xelatex or lualatex (no with pdflatex). If it works, reconstruct your template for here, but forgetting all your previous font settings (that are for pdflatex).
    – Fran
    Apr 13, 2023 at 5:33

0

You must log in to answer this question.

Browse other questions tagged .