2

My goal is to install commercial font GT-America to use with TeX. The font consist of several .otf files.

What I did so far:

  • Installed all the fonts using sudo autoinst
  • Ran sudo texhash and sudo updmap -sys afterwards
  • Ran pdflatex with my sample document

The error that occured: If I run pdflatex for my file, it almost finishes, but then it gets stuck on this error:

--mfmode / --bdpi 600 --mag 1+150/600 --dpi 750 GTAmerica-CondensedBold-lf-t1--base                                                                                                    
mktexpk: don't know how to create bitmap font for GTAmerica-CondensedBold-lf-t1--base.
mktexpk: perhaps GTAmerica-CondensedBold-lf-t1--base is missing from the map file.

What I've tried to solve the issue:

  • Cleaned the config file in my directory
  • Took a look at the map folder in /usr/share/texmf/fonts/map/dvips/GTAmerica, the font seems to be there

My setup:
Linux 6.2.10-1-MANJARO (64-bit)
TeX 3.141592653 (TeX Live 2023/Arch Linux)
kpathsea version 6.3.5

If anybody has a clue or could point me to the right direction, I'd be really grateful.

4
  • .odf, or .otf ? assuming the latter it is much easier to use lualatex or xelatex, do you have an absolute requirement to make a subset of the font converted to work with pdflatex? Apr 15, 2023 at 12:06
  • You need to enable the map files created by autoinst. Apr 15, 2023 at 12:26
  • something like updmap-sys --enable Map=GTAmerica.map or however it is called. Apr 15, 2023 at 12:35
  • I don't really know how I did it, but somehow using the command above it's now working in pdflatex. Now wish me luck reimplementing this in Docker :D Thank you so much, you saved me tons of work. Apr 15, 2023 at 12:47

1 Answer 1

0

The updmap-sys --enable Map=GTAmerica.map command worked after issuing sudo texhash and sudo updmap-sys. After that the file gets compiled even with pdflatex.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .