1

I had previously posted a question about Arara, with TeXlive 2022 and with specific reference to ConTeXt (see ConTeXt and Arara, failure. That question has been closed due to "lack of clarity", and I have abandoned it in lieu of this new question.

So: I now have TeXlive 2023 installed from ISO -> USB method (see 2023 TeXlive install failure. When I attempt to run Arara within TeXstudio, TeXworks, or Kile, arara simply gives me the 'splash' display, as so:

Usage: arara [OPTIONS] file...

    __ _ _ __ __ _ _ __ __ _
   / _` | '__/ _` | '__/ _` |
  | (_| | | | (_| | | | (_| |
   \__,_|_|  \__,_|_|  \__,_|

  The cool TeX automation tool.

  arara executes the TeX workflow you tell it to execute. Simply specify your
  needs within your TeX file and let arara do the work. These directives
  feature conditional execution and parameter expansion.

Options:
  -l, --log                        Generate a log output
  -v, --verbose / -s, --silent     Print the command output
  -n, --dry-run                    Go through all the motions of running a
                                   command, but with no actual calls
  -S, --safe-run                   Run in safe mode and disable potentially
                                   harmful features. Make sure your projects
                                   uses only allowed features.
  -w, --whole-file                 Extract directives in the file, not only in
                                   the header
  -p, --preamble TEXT              Set the file preamble based on the
                                   configuration file
  -t, --timeout INT                Set the execution timeout (in milliseconds)
  -L, --language TEXT              Set the application language
  -m, --max-loops INT              Set the maximum number of loops (> 0)
  -d, --working-directory PATH     Set the working directory for all tools
  -P, --call-property VALUE        Pass parameters to the application to be
                                   used within the session.
  --generate-completion [bash|zsh|fish]
                                   Generate a completion script for arara. Add
                                   'source <(arara --generate-completion
                                   <shell>)' to your shell's init file.
  -V, --version                    Show the version and exit
  -h, --help                       Show this message and exit

Arguments:
  file  The file(s) to evaluate and process

NOTE: I view this is an improvement of sorts when compared to the prior error that I had, wherein arara told me that it **could not access the arara.jar file**

NOTE: I can successfully run arara from the terminal window, but ONLY if the terminal window is opened from the folder where the 'my_document.tex' file resides:

username@username-computername:~/Documents/documents_2022_2023/specific_documents$ arara my_document.tex
  __ _ _ __ __ _ _ __ __ _
 / _` | '__/ _` | '__/ _` |
| (_| | | | (_| | | | (_| |
 \__,_|_|  \__,_|_|  \__,_|

Processing "my_document.tex" (size: 7.1 kB, last modified:
2023-04-15 19:52:08), please wait.

(LuaLaTeX) LuaLaTeX engine .............................. SUCCESS

Total: 1.513 seconds
username@username-computername:~/Documents/documents_2022_2023/specific_documents$ 

IF, on the other hand, I execute the same command from the same directory, under Root control:

username@username-computername:~/Documents/documents_2022_2023/specific_documents# arara my_document.tex

the operation fails. It issues a reply,

root@username-computername:/home/username/Documents/documents_2022_2023/specific_documents# arara my_document.tex
Error: Unable to access jarfile
root@username-computername:/home/username/Documents/documents_2022_2023/specific_documents

It seems to me that the behavior in terminal mode must offer some clue(s) as to why I cannot get arara to run in any of the TeX-specific editors. Clearly, it has something to do with permissions. But, I cannot see and understand where it comes off the rails, so to speak.

8
  • “IF, on the other hand, I execute the same command from the same directory, under Root control”: I would assume that in root you do not have set up all necessary paths for TeX Live which seemingly do work in your user. However, you should never run something like arara (which can execute arbitrary system commands) as root.
    – TeXnician
    Apr 23, 2023 at 10:38
  • “When I attempt to run Arara within TeXstudio, TeXworks, or Kile, arara simply gives me the 'splash' display, as so” Do you have any means of getting the command-line that these editors try to run (and the exit code they get)? arara will only output said splash screen if it is run without arguments or with the help flag. Neither of which any editor should run. Are you sure that the editors actually pass on the file argument?
    – TeXnician
    Apr 23, 2023 at 10:39
  • In TeXstudio, I have set up a user-command which is arara | "/usr/local/texlive/2023/texmf-dist/scripts/arara/arara.sh" | "/usr/local/texlive/2023/texmf-dist/scripts/arara/arara.jar"
    – Birdman
    Apr 23, 2023 at 17:41
  • in Kile, the arara command is /usr/local/texlive/2023/bin/x86_64-linux/arara
    – Birdman
    Apr 23, 2023 at 17:42
  • I used the arara "generate completion" option, generated a bash completion file, and put it in the bash-completion folder as, usr/share/bash-completion/completions/arara. This doesn't seem to be the answer, unless the system needs to be re-booted or "sourced"
    – Birdman
    Apr 23, 2023 at 17:44

1 Answer 1

1

After carefully examining the compiling commands (pdflatex, lualatex...etc) within each of the editors (TeXworks, TeXstudio, Kile), I have solved my own problem. A clue came from the fact that, although Arara would run from the terminal, when it was called from within these TeX editors, it would display the same "splash" screen as found at the terminal were you to run the command $ arara, without specifying a target file to process.

I still have NO idea of how all three of these editors came to simultaneously have the same issue with running Arara (they were running fine previously). It will probably remain a mystery.

As I hinted above, in every case the problem arose from within the editor because Arara was not supplied with a *.tex file-name to work on (NB: my intuition that the compiler would automatically [magically?] use the file that was "in progress", was wrong.)

The editor must be set-up to supply the *.tex file-name when Arara is called. Here are the setup requirements for each editor that I've been experimenting with:

For TeXstudio: Go to OPTIONS --> Configure TeXstudio --> Build --> User Commands; choose "+Add" , then add this Path to the arara program (placed inside double quotes, as shown below), to which it is appended %.tex: "/usr/local/texlive/2023/bin/x86_64-linux/arara" %.tex Click OK to exit. Check your editors function with a known-good *.tex file that compiles with a known compiler (say, pdflatex); for example, add % arara: pdflatex as the first line of your preamble. NOTE: with ConTeXt, you will have to use the suffix .tex for your working file, even though the ConTeXt team doesn't recommend using the normal *.tex extension (to distinguish them, my ConTeXt documents now appear as my_filename.mkiv.tex) ****.

For TeXworks: from the menu, choose Edit --> Preferences -->Typesetting; Choose (or create anew) the Processing Tool from the list; then click Edit...; then in the Tool Configuration Menu enter Name: arara Program: arara Arguments: $fullname (you may choose to "view PDF after running") Click OK. Test your system with a known good *.tex file, using arara as the compiler, as suggested above

For Kile: From the menu, Settings --> Configure Kile --> Build Select the tool arara (or add it, if necessary); then you will have to configure the tool using the 3-tabbed menu on the right; Select: Default {<---See my note at ***, below} Under the "General" tab, choose Command: arara Options: %source Under the "Advanced" tab, Type: Run Outside of Kile Class: Compile Source Extension: (leave blank) Target Extension: PDF Target File: (leave blank) relative dir: (leave blank) (click OK) Test your Kile editor with arara, as outlined above

To recap: the .tex file to be compiled is tagged in three different ways: In TeXstudio, it is ".tex"; In TeXworks, it is "$fullname"; and, In Kile, it is "%source"

*** A 2nd configuration might be added, specifically for ConTeXt using a specific engine (ConTeXt-Lualatex, for example), but I have not tested this

****It is likely that a 2nd User Command (named "arara-Context", for example) can be added, with a different file extension as the target (for example, %.mkiv), but I have not tested this yet

18
  • 3
    To me it more seems like you haven't setup the PATH correctly. How did you do that? If the PATH is set correctly you don't need full paths to programmes in the settings of the editors.
    – daleif
    Apr 25, 2023 at 7:53
  • Further comment: arara does not need the .tex extension. If you have a file mytex.tex it will run just fine being called as arara mytex. Changing %.tex to % will therefore still work and solve your ConTeXt problem in TeXStudio.
    – TeXnician
    Apr 25, 2023 at 19:46
  • What changes would be needed to set-up the PATH correctly?
    – Birdman
    Apr 25, 2023 at 20:45
  • In TeXstudio, I just changed %.tex to (first) %, then to %. , then to %.mkiv --- In all three cases, I got the same error message from Arara:
    – Birdman
    Apr 25, 2023 at 20:50
  • that error msg being "I could not find the provided file "new_context." [ .tex | .dtx | .ltx | .drv | .ins ]. Please make sure the file exists and it has a valid extension."
    – Birdman
    Apr 25, 2023 at 20:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .