3

I am using LyX to write my thesis. I am using a BibTeX Generated Bibliography (generated in Jabref) which works fine. I just have one problem, in the actual PDF, the Bibliography section after each reference, the section where that reference was cited is printed out, for example:

[1] R. Budwig, “Refractive index matching methods for liquid flow investigations,” Experiments in Fluids, vol. 17, no. 5, pp. 350–355, 1994. 2.7.4

Where "2.7.4" is the section where this reference is cited.

Is this related to my overall master style file, or is it just a simple setting in LyX that I can disable?

3 Answers 3

2

Usually the back references are inserted by package backref. Either it is loaded explicitly or it is loaded by package hyperref via options backref or pagebackref. I am not familiar with Lyx, but at least you have some hints, what needs to be changed.

1
  • Thank you! I found the problem, in my Latex Preambles i had backref as one of the packages to use. Thank you!!!!
    – Emma
    Aug 24, 2012 at 9:08
3

I was able to fix this problem easily in lyx by going to: document -> settings -> PDF Properites and then unchecking the "Use Hyperref Support."

If I kept the \usepackage{hyperref} in the preamble, doing the above would just get rid of hyperlinks from the bibliography entries. If I got rid of \usepackage{hyperref}, doing the above would eliminate all hyperlinks throughout the document.

3
  • It's not clear that this actually answers the question. The OP is interested in just eliminating the back references in the bibliography, not all hyperlinks in the document.
    – Adam Liter
    Dec 24, 2013 at 19:32
  • "would just get rid of hyperlinks from the bibliography entries." In other words -- it gets rid of backrefs in the bibliography.
    – user43174
    Dec 24, 2013 at 21:12
  • Is it possible to make it so the references contain the page numbers (in order) that the reference appears on? Mar 6, 2018 at 4:37
2

You can remove the section numbers from the bibliography as follows:

Document -> PDF Properties -> Hyperlinks -> Backreferences -> Off

1
  • This is the correct answer, thanks (+1). By the way the correct chain is Document -> Settings... -> PDF Properties Hyperlinks -> Backreferences -> Off
    – lcv
    Apr 14, 2020 at 21:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .