I've tried so many fonts and none of them work, all I get is:

! LaTeX Error: File `ebgaramond.sty' not found.

This is an example of what I have on my document, though I've tried many others:


People have told me XeLaTeX or LuaLaTeX would have these fonts with fontspec right out of the box, but that doesn't seem to be the case at all.

Here is my current version of XeLaTeX:

XeTeX 3.141592653-2.6-0.999995 (TeX Live 2023/Arch Linux)
kpathsea version 6.3.5
Primary author of XeTeX: Jonathan Kew.
Compiled with ICU version 72.1; using 72.1
Compiled with zlib version 1.2.13; using 1.2.13
Compiled with FreeType2 version 2.13.0; using 2.13.0
Compiled with Graphite2 version 1.3.14; using 1.3.14
Compiled with HarfBuzz version 7.1.0; using 7.2.0
Compiled with libpng version 1.6.39; using 1.6.39
Compiled with pplib version v2.05 less toxic i hope
Compiled with fontconfig version 2.14.2; using 2.14.2

And my version of LuaLaTeX:

This is LuaHBTeX, Version 1.16.0 (TeX Live 2023/Arch Linux)
Development id: 7567

Is there a command on either XeLaTeX or LuaLaTeX for installing fonts? What am I missing?

  • How did you install your TeX installation? I used TeXlive (Windows) and can compile correctly with the ebgaramond font, it may have been your installation being minimal perhaps
    – JamesT
    May 7 at 16:42
  • You are using a TeX Live package from arch linux. Usually linux distributions split TeX Live into several packages. So you may have to search ebgaramond.sty with the file search of your linux package manager to find the corresponding linux package. Often names like texlive-fontsextra or something like this is used. Another suggestion would be to install the full TeX Live. Usually there is a package like texlive-complete or texlive-full to do so.
    – cabohah
    May 7 at 16:49
  • Omg, I had installed TeX Live from a weird package because I do remember installing the full version. But right now I tried to do it again with yay -Syu texlive-full and it finally works! May 7 at 18:01

1 Answer 1

luafindfont ebgaramond

will show you which Garamond are installed. If the output is empty you have to install the Garamond package: https://www.ctan.org/pkg/ebgaramond

And with


you can load Garamond without the package ebgaramond.

  • Indeed. Worth noting that a lot of users install Type1 font packages, possibly out of force of habit, possibly due to online advice that is 10 years out of date. Some OpenType/TrueType fonts do not come with a *.sty file. Others do, for special purposes.
    – rallg
    May 7 at 18:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .