1

I want to submit an article to a journal and it has its own template with its own document class (available here). I can compile the tex file into a pdf (although with error messages), but the references don't show up (they are in a separate bib file).

Consider the following working example (I use the template's bib file):

\documentclass{rQUF2e}

\begin{document}

\title{Whatever}

\author{Whoever}

\maketitle

\begin{abstract}
Blablabla
\end{abstract}

\section{Introduction}

To estimate the risk-free term structure, do this \citep{ed84}.

\bibliographystyle{rQUF}
\bibliography{rQUFguide}

\end{document}

The following error message appears:

This is BibTeX, Version 0.99d (TeX Live 2022)
The top-level auxiliary file: proba.aux
The style file: rQUF.bst
Database file #1: references.bib
Warning--I didn't find a database entry for "["
(There was 1 warning)
Process exited normally

In the pdf, the \citep{ed84} command appears as [?,]]ed84.

I am unable to fix this and a topic with a similar problem didn't help.

I also tried with the journal's example tex file and bib file, but the same happens.

I tried it in Texstudio under Windows 10 and Mac OS Ventura 13.2.1.

5
  • 2
    Hi, welcome! I am afraid that without more data and an example of code that fails, it will be impossible to find a solution. Please try to produce a minimal working example with bibliography (MWEB), or at least say which journal and which template is...
    – Rmano
    May 10, 2023 at 13:16
  • Ok, I'll edit the post with a working example. Thanks!
    – sebszab
    May 10, 2023 at 15:17
  • Also, "compiling with error messages" doesn't count. If there's an error message, the pdf is a guide about what TeX thinks happened. But you need to resolve errors messages before you can worry about what the pdf looks like. (This doesn't apply to warnings.)
    – Teepeemm
    May 10, 2023 at 15:30
  • It's true, but as long as it generates the document to be submitted, I'm fine with that. In a standard article class, there is no error message and everything works fine. And to be honest, Latex error messages are always a mystery to me as I have difficulties to understand them.
    – sebszab
    May 10, 2023 at 15:39
  • @sebszab, the format is very old and doing questionable things, like overriding system packages. Fortunately, a rollback can magically make it work again, see my answer. But the editors should think about changing it (also, it uses OT1 encoding ... brrrr)
    – Rmano
    May 10, 2023 at 18:09

1 Answer 1

4

What you posted is not an error, it's just a warning from bibtex. The are numerous errors when compiling the main file, starting with:

! LaTeX Error: Command \negmedspace already defined.
               Or name \end... illegal, see p.192 of the manual.

and ending with a worrying

! Extra \endgroup.
\document ->\endgroup 
                      \ifx \@unusedoptionlist \@empty \else \@latex@warning@...
l.3 \begin{document}

If you look closely, the "package" you are pointing to is overriding system files, namely:

amsbsy.sty amsfonts.sty amsmath.sty amssymb.sty epsfig.sty graphicx.sty natbib.sty rotating.sty subfigure.sty

which is a no-no. If I remove all that files (so using the distribution's one), there are fewer errors, but the Extra endgroup error stays, and now there is a new one (on the second run)

(./proba.bbl
! Undefined control sequence.
<argument> \@bibsetup 
                      {0}\global \c@NAT@ctr \z@ 
l.1 \begin{thebibliography}{0}

which explains why the bibliography is not built.

CONCLUSION: The class is utterly broken, you have to talk to the journal's editors.

BUT THERE IS A WORKAROUND

If you read the source, the class has been last updated in 2014, and it has used the policy of modifying internal things. If you add the line (thanks to David Carlisle)

\RequirePackage[2018-12-01]{latexrelease}

before the documentclass, so that the LaTeX kernel is "backported" to the past, the compilation works, so if you compile, call bibtex, and compile two times more you'll have:

enter image description here

Still, the format is broken and seems unmaintained since 2014, which is a lot of time...

1
  • Amazing answer, thanks a lot! Now it seems to work. I never really understood the Extra endgroup type of errors, they are not clear to me at all. The class is then definitely broken and I'll let them know. I tried to use the hyperref package as well, but it didn't work either.
    – sebszab
    May 10, 2023 at 18:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .